3

This mouse is a "low-power bluetooth" device. Supposedly this uses HOGP instead of HID.

I have found responses that say you need bluez 5.x. Well Ubuntu 15.10 has bluez 5.35 but it doesn't work. When you try to make a connection, it identifies the mouse as "any device" and won't connect. I have a Surface Pro3 running either the distributed kernel for Ubuntu 15.10 or a more useful kernel that I have built myself based on a patched linux 4.3--the mouse behavior is the same for either. THe hardware is by Marvell. The mouse works perfectly when used in the Windows 8.1 partition.

4

The solution was described here in comment #9: https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1510570

In few words:

  1. Comment out the only non-commented line in file /lib/udev/rules.d/50-bluetooth-hci-auto-poweron.rules
  2. Uncomment lines [Policy] and AutoEnable=true (originaly there is =false, change it) in /etc/bluetooth/main.conf
  3. Reboot
  4. Search and pair your mouse. If cursor is not moving, try pairing again.
8
  • Sorry Andrey, This doesn't help (though I didn't try the ppa thing in bug 1510570). It doesn't know it's a mouse for one thing... Nov 16 '15 at 1:50
  • It's pity. I didn't use this ppa, just changed 2 config files and rebooted. After I had paired my Microsoft Arc Touch Mouse it still stayed nonoperable but after the second attempt all became ok. Despite the fact that System Settings -> Bluetooth shows it as "Type: All Types", not "Type: Mouse". Nov 17 '15 at 2:35
  • I tried some more. Just doesn't work. However putting the rule 50 in causes lots of lengthy USB failures before the system completes booting. Nov 17 '15 at 19:18
  • With the released Ubuntu 4.2.0-18 kernel I actually got it to work once; not repeatable. Never any success with my purpose-built 4.3. Also the strange startup slowness has vanished. Nov 19 '15 at 14:45
  • I noticed the startup slowness too. Nov 20 '15 at 14:56
1

Just wanted to add to the Andrey's Answer. If you disable the rule, the bluetooth is not active on the login screen. Even though in launchapd they say 5.35 removes the problem, I still experienced it. Anyway if you are like me using BT keyboard to log in, you might want to do as Andrey say and then reboot and remove the comment in the /lib/udev/rules.d/50-bluetooth-hci-auto-poweron.rules then reboot and the mouse is still connected.

0

On Ubuntu 15.10 (on Lenovo yoga 13) I was able to get Microsoft Design mouse working directly around the first couple weeks since the 15.10 release.. I think I was issuing some commands directly into the bluetoothctl utility to discover/pair the mouse instead of usual desktop GUI (I was having issue with my bluetooth driver that had a bug). The steps were these as I recall:

scan on
(now put mouse in pairing mode, wait for it to show up in console)
pair (the mouse's mac address)
connect (the same mac address)

I've used Design mouse for many weeks now - it works fine, but have a different issue - if I don't use the mouse for like 10 minutes then it become 'turned off'. I can turn it back on from the desktop bluetooth menu and it'd work fine as long as I keep it active. Alternatively, you can turn it on from bluetoothctl command utility once it goes to sleep, e.g.

connect (the mac address for your mouse)

You can write a bash script and run it from a keyboard shortcut, but still I wish it'd get fixed soon.

p.s. This works without hacking the udev rules and bluez conf file.

2
  • The 4.4 Linux Kernel series reconnects even after the 10 minutes or (usually) a reboot. My roll-your-own is 4.4-rc2 which has a building problem but that is known and probably will already be fixed in rc3. Nov 30 '15 at 14:37
  • after upgrade to ubuntu 16.04, which runs 4.4 kernel, my Microsoft design mouse (BLE) does work, but when it goes to "sleep" I cannot wake it up from the the bluetooth menu (or command line).. what changed I wonder..
    – Bill
    Apr 23 '16 at 14:24
0

I've tried everything written before without success; but I was able to get the Microsoft Designer mouse working using blueman. After installed I needed to play with it a little bit, but it works!. Remember after restarting you have to initiate blueman and just click on the Desiner Mouse option to connect it properly. BTW, using blueman the mouse doesn't stop every 10 minutes; but now I have some problems on WIFI speed :(

1
  • 1
    Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) Dec 14 '15 at 19:01
0

I similar thread on a MacOS forum solved this for me:

  • remove all other BT devices
  • pair the designer mouse: it should now work
  • re-add the other BT devices

Basically the designer mouse will only work if it's the first BT device.

https://discussions.apple.com/thread/6987906?start=0&tstart=0

0

Just want to add another success story. NOTHING worked until I removed all Bluetooth devices, rebooted, used Setup new device utility in Blueman. Works perfect now. No issues.

Works on 16.04LTS using same meathod as well

0

As others have said, workarounds can be found here: https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1510570
There seems to be several ways and several combinations to work around the problem in the page described.

Adding to Andrey's answer, comment #27 on the page describes the following:

  1. Comment out the only non-commented line in /lib/udev/rules.d/50-bluetooth-hci-auto-poweron.rules. You may also replace it completely with the line below.

  2. Add ACTION=="add", SUBSYSTEM=="bluetooth", KERNEL=="hci[0-9]*", ENV{DEVTYPE}=="host", RUN+="/bin/hciconfig %k up".

Many thanks to all involved. Helped me a bunch !

0

Okay. I have searched every where and finally did the same thing as what was described in https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1510570 after you follow those steps, be sure to open the bluetooth manager, select the mouse and the keyboard, and delete those connections. take the batteries out of both and put them back in to hard reset the devices, then turn them both on in pairing mode (intermittent flashing, 1 sec on, 1 sec off), and search for new devices on the bluetooth manager. While the device is still in pairing mode with the flashing light, select it and press the setup button. If you wait too long the devices won't be in pairing mode anymore and you might have to start over to get it to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.