I recently bought a new laptop and I would love to install Xubuntu 15.10 next to the current Windows 10 installation. The laptop I bought is a the ASUS ROG GL552VW-CN104T. The CPU of this laptop is the Intel Core i7-6700HQ and the GPU of this laptop is the NVIDIA GeForce GTX 960M. I think the problem is in support for the CPU, as it is a new Skylake processor.

I put xubuntu-15.10-desktop-amd64.iso on my USB drive and selected the boot device UEFI: KingstonDataTraveler 2.01.00, Partition 1. After this GRUB (version 2.02~beta2-29) would start up and give me the option to try, install, OEM install and check the disc. I chose e to edit the commands before booting.

By default it was set to the following:

setparams 'Try Xubuntu without installing'
  set gfxpayload=keep
  linux    /casper/vmlinuz.efi  file=/cdrom/preseed/xubuntu.seed boot=casper quiet splash ---
  initrd    /casper/initrd.lz

I changed the third line to:

  linux    /casper/vmlinuz.efi  file=/cdrom/preseed/xubuntu.seed boot=casper i915.preliminary_hw_support=1 ---

Still it would not boot up and show me the desktop.

I also changed the third line to:

  linux    /casper/vmlinuz.efi  file=/cdrom/preseed/xubuntu.seed boot=casper nouveau.modeset=0 i915.preliminary_hw_support=1 ---

But still it would not boot up and show me the desktop.

I also tried using a DVD instead of a USB, but it had the same results. And I also tried adding the newest 4.3 kernel (downloaded from the kernel website of Ubuntu at /~kernel-ppa/mainline/v4.3-wily) to the Xubuntu live cd following this tutorial and LiveCDCustomization at the Ubuntu website, which was already pretty hard, but it would not boot up either (with or without the nomodeset and/or i915 parameters).

Here are a few photos to clarify my issue.

How can I boot Xubuntu 15.10 on this laptop and install it to the SSD next to Windows 10?

Edit: I already tried the solution in the 'duplicate', but this did not work for me.


Got Ubuntu 15.10 installed, on this exact same model laptop. Took me most of today to figure this out.

  1. I turned off secureboot and turned on UEFI and PCXE via the Bios. Hit Esc at boot, and choose 'settings' to access this. I also turned on the networking stack -- though I don't know if this was necessary.

  2. You need to turn off fast startup in Windows 10 via the instructions at


This is assuming that you want to dual-boot

  1. After booting, hit escape, and choose the appropriate UEFI entry. In my case, it was the DVD.

  2. Choose either 'Run without installing' or the 'setup' option from the GRUB2 menu. However, instead of hitting enter, type 'e' to edit.

Make the following changes:

"set gfxpayload = 1920x1080 "

and replace the 'quite spash ---' section of line 3 with the following entries (they all force various option on that would not be turned on otherwise, and also enable the latest Intel chipset support.

"nomodeset i915.preliminary_hw_support=1 nouveau.blacklist=1 edd=on nolapic pcie_aspm=force tpm_tis.interrupts=0 ---"

  • I got it booting with this! Thank you! Almost everything works except the touchpad, does the touchpad work for you? – Robin van der Vliet Nov 28 '15 at 18:18
  • I just noticed that also only my first core works (because of the nolapic). How did you fix those problems? – Robin van der Vliet Nov 29 '15 at 23:24
  • I have upgraded the kernel to 4.3, which should probably solve the Skylake problems. However, there are other problems happening with the Nvidia GTX 960M card. Still working away at it (albiet slowly). Having only a single core on a gaming laptop is no fun :-( On the bright side, this will eventually be resolved though. – skhansj Dec 9 '15 at 19:07
  • I also upgraded to Linux 4.3, but the boot parameter 'nolapic' is still required for a succesfull boot. This parameter causes that only a single core is usable. I did not even look yet at the graphical card, but I thought that was easier to setup with Bumblebee. – Robin van der Vliet Dec 13 '15 at 10:29

You may need to go with all the settings skhansj provided, but I had success on 3.x and 4.x kernels with this same computer using the following:

"i915.preliminary_hw_support=1 nouveau.modeset=0 acpi_osi=! acpi_backlight=native idle=nomwait"

Using the above, I had all 4 cores running and the function keys worked for LED and screen control. You might need to press the LED down first and then up because the OS seems to think the think is at full power even though it is at zero on startup.

I still have not solved touchpad. I've tried a variety of i8042.x commands at boot but have not found one that works yet. I will certainly let you know.. I even went and built 4.3.3 last night and included all the right i2c and psmouse stuff directly in the kernel and it was not successful.

I had NVIDIA working on the ppa drivers but I have since disabled it becuase I am getting great support out of the intel driver in 4.3 (which I compiled direct into kernel rather than making a module).

Also: On 4.3.x kernels you can drop the preliminary hw support, and you can drop the nouveau overrides on startup once you have configured your drivers. I kept nouveau.modeset=0 in my cmdline even on 4.3 just because I want to ensure I don't boot in that mode.

  • Touchpad is solved. On Linux 4.3.3, you need to have the i2c_designware bus support (i2c-designware-pci.ko and designware-platform.ko) as this is apparently under the hood on this machine. – dvishnesky Jan 13 '16 at 4:47

On ubuntu 16.04 ( I struggled with ubuntu while didn't want to install xubuntu) just set nouveau.modeset=0. Courtesy to this answer. set this parameter before quiet splash --- like nouveau.modeset=0 quiet splash ---

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.