0

After upgrading to Wily I get this error "failed to start etc/rc.local" It also says see "systemctl rc-local.service ubuntu":

startup

I am getting problems each time I want to modify /.zshrc it tells me another one is using it, suggesting if I want to recover it.

I am using ohmyzsh as a terminal and editing ~/.zshrc to add programs to the PATH. Using Ubuntu GNOME. Thanks in advance for your help.

  • 1
    Is it /etc/rc.local or etc/rc.local? What does this tell us? cat /etc/rc.local? – chili555 Nov 5 '15 at 16:19
  • This #!/bin/sh -e # # rc.local # # This script is executed at the end of each multiuser runlevel. # Make sure that the script will "exit 0" on success or any other # value on error. # # In order to enable or disable this script just change the execution # bits. # # By default this script does nothing. xinput -set-prop 13 139 0 exit 0 I added that xinput line to fix some wrong behavior with the trackpoint. – Andrés Parada Nov 5 '15 at 19:20
  • 1
    I wonder if this is the problem: askubuntu.com/questions/534203/why-wont-rc-local-run-xinput Please note: xinput requires the X Window System to be running. But it's not running yet at the time rc.local is executed. – chili555 Nov 5 '15 at 23:10
  • Thanks, I removed that xinput line at it worked! It wasn't working properly anyway and was fixing the trackpoint issue with a custom script. – Andrés Parada Nov 6 '15 at 3:01
  • 1
    @chili555: you should add your comment as answer, so the questioner can accept your Answer as solved – rubo77 Apr 21 '16 at 7:59
0

Thanks, I removed that xinput line at it worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.