1

So, I recently switched from Windows to Linux. I'm still a beginner at this so be easy and please be very clear. Before I made the switch, I transfered all of my important files (about 8GB in total) to my tablet and every time I tried to just transfer them to my desktop, something went wrong and a few files don't get transfered. So I decided to transfer them wirelessly using Airdroid. I downloaded the files in a .zip format and extracted them to my desktop. No errors there until I tried to open the subfolders and it says I can't access them because either I don't have permission or access is denied. There's also a little lock icon on the folders, but I've noticed that even on the folders that don't have the the lock icon sometimes I can't access them.

I've changed the Permissions on properties for some of the files but there are so many and I can't spend so much time. Plus, there may be other times I'll download from my tablet through Airdroid and I need to have a fast option.

I've tried sudo apt-get install nautilus-open-terminal command line but it even that does not work after it's downloaded and installed (I don't see the open in terminal option in the right click list).

Is the problem coming from the extractor? What should I do?

1

it happened that extracting these files have a different owner with whom the user logged on Linux.

You have to do so, open a terminal (press Alt + F2 and write

gnome-terminal

in the box and hit enter).

In the terminal run the command id:

[lillox@lillomachine ~]$ id

take note of your uid and gid, again in the terminal write

cd ../Desktop

and then (using your values instead of and )

chown -R <uid>:<gid> *

This command changes the owner to all files and directories on your desktop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.