5

I used GNU TeXmacs very often for maths related stuff for university. Now completely wiped my old Ubuntu installation and directly installed Ubuntu 15.10 from disc. After installing all updates I tried

sudo apt-get install texmacs

The terminal said it was no longer available. Then I tried manually installing it with instructions on the official website, but after I was done, I still couldn't start it. I also tried uncommenting all repos in sources.list.

0
3

The package is not available anymore, that's right. You can install the Vivid packages.

  1. Re-enable the repositories in sources.list

  2. Download, e.g. for 64-bit

    cd
    wget http://mirrors.kernel.org/ubuntu/pool/universe/t/texmacs-extra-fonts/texmacs-extra-fonts_0.2_all.deb
    wget http://mirrors.kernel.org/ubuntu/pool/universe/t/texmacs/texmacs-common_1.0.7.18-1_all.deb
    wget http://mirrors.kernel.org/ubuntu/pool/universe/t/texmacs/texmacs_1.0.7.18-1_amd64.deb
    
  3. Install

    sudo dpkg -i texmacs*.deb
    

Possibly there are some missing dependencies but that is no problem, just execute the command in the next step.

  1. Install the missing dependencies

    sudo apt-get install -f
    
8
  • Thank you for your answer. I did all as you said, but the program still doesn't show up in my applications list... (I'm sorry but I'm not that experienced with Ubuntu) – s.t Nov 6 '15 at 14:43
  • Some error messages during the installation? – A.B. Nov 6 '15 at 14:48
  • What's the output of apt-cache policy texmacs – A.B. Nov 6 '15 at 14:49
  • texmacs: Installed: (none) Candidate: (none) Version table: 1:1.0.7.18-1 0 100 /var/lib/dpkg/status – s.t Nov 6 '15 at 18:58
  • Do you have the downloaded files? – A.B. Nov 6 '15 at 19:02
3

You can also download the current TeXmacs binary file .

Unpack the zip file to a directory of your choice. Then follow the installation instructions, which just involve setting the proper paths:

Set the environment variables.
Let [installation directory] be the current directory,
which contains this file. Depending on your shell, either type

   setenv TEXMACS_PATH [installation directory]
   setenv PATH $TEXMACS_PATH/bin:$PATH
or
   export TEXMACS_PATH=[installation directory]
   export PATH=$TEXMACS_PATH/bin:$PATH

After that, TexMacs ran fine, although there were a few warnings about missing fonts.

One advantage of using the binary is that is provides the newest TeXmacs 1.99 while Vivid and Trusty use 1.0.7

3
  • Thank you for your answer. However, I already tried that one and still can't see the application show up in the app list... – s.t Nov 6 '15 at 14:44
  • It won't show up in the app list automatically. You need to start it from the unzipped folder. You can make a .desktop file and put it in /usr/share/applications or, better, ~/.local/share/applications. I'll add this to the answer shortly. – chaskes Nov 6 '15 at 15:04
  • Where is the desktop file? ;) – A.B. Nov 10 '15 at 8:21
3

Texmacs is no longer available in Ubuntu repos because it depends on Guile-1.8 which is considered deprecated by Debian (and hence not in the repos anymore).

However TeXmacs is still being developed and current .deb packages for all recent Ubuntu versions are available at opensuse.org/download.html?project=home:slowphil:texmacs-devel which is more or less like a PPA, except it's not Ubuntu-exclusive.

These .deb files are far easier to install than the static package available at texmacs.org mentioned in chaskes' answer; they are also much more recent with many bug fixed. For instance input methods based on ibus work with the debs but are broken in the static package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.