1

I've seen other similar questions but they don't solve my problem unfortunately.

I've been added to the sudo group on my Ubuntu 14.04 with

usermod -aG sudo testuser

but I still can't run sudo:

 :~$ groups
     testuser sudo
 :~$ sudo -s
     testuser is not allowed to run sudo ...

I can't add:

testuser ALL=(ALL:ALL) ALL

to the /etc/sudoers. I've tried also:

 sg sudo

I've tried to logout and login again into the machine. Do you have any ideas?

I don't have sudo access and so I can't run:

sudo grep sudo /etc/sudoers | grep -v "#"

but I saw before that the line with

%sudo   ALL=(ALL:ALL) ALL

is not commented out.

SOLUTION

At the end was just a problem of administration. The admin had to give me the sudo access for that machine inside another setting (I don't know how and not with usermod) also if I was already inside the sudo group, now it works. Thanks all.

  • 1
    Please edit your question and post the output of sudo grep sudo /etc/sudoers | grep -v "#" – terdon Nov 5 '15 at 13:28
  • That solution isn't really a solution. There's no detail about what needed to be done to fix the issue. – user1751825 Aug 20 '16 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.