7

I installed Ubuntu Studio 15.10 and upon that:

sudo apt-get install ubuntu-desktop

Now on the login screen, I have the default brownish Ubuntu default background.

  • I tried this as root:

    sudo xhost +SI:localuser:lightdm
    sudo su lightdm -s /bin/bash
    gsettings set com.canonical.unity-greeter background /usr/share/backgrounds/Tranquil_by_Pat_David.jpg
    

    But this didn't change anything.

  • Also starting the unity-control-center as user lightdm and changing the background there had no effect.

  • I also checked the rights of /usr/share/backgrounds/Tranquil_by_Pat_David.jpg which are globally readable.

4
  • This is a Duplicate
    – T04435
    Commented Nov 5, 2015 at 10:45
  • 2
    It is not a duplicate, I tried everything in that question
    – rubo77
    Commented Nov 5, 2015 at 11:01
  • 1
    Maybe a bit duplicate indeed, cause the answer was in one of the low voted answers: askubuntu.com/a/360008/34298
    – rubo77
    Commented Nov 5, 2015 at 11:08
  • I've updated my answer, please refer Commented Nov 18, 2015 at 4:41

4 Answers 4

23

The proper way of changing default unity-greeter background is through overriding glib-2.0 schema, as specified in the Lightdm Ubuntu Wiki

The steps are as follows:

  1. Create /usr/share/glib-2.0/schemas/10_unity_greeter_background.gschema.override file with the following contents:

    [com.canonical.unity-greeter]
    draw-user-backgrounds=false
    background='/foo/wallpaper.png'
    
  2. Run sudo glib-compile-schemas /usr/share/glib-2.0/schemas

  3. Reboot or login to TTY2 (accessed by pressing Ctrl+Alt+F2 ) and run sudo service lightdm restart

This has been tested on my Ubuntu 14.04

Update: November 17 2015

I have put together a script that simplifies the process of changing the greeter background. It has been tested in its final form on two versions of Ubuntu, 14.04 LTS (actual physical machine ) and 15.10 (Virtual Machine ) It can be found in my GitHub

9
  • Thanks for your script! It, however, produces this error when running.
    – orschiro
    Commented Oct 6, 2016 at 6:21
  • 1
    @orschiro you have to call script with path to file. For example, sudo ./chgreeterbg.sh /home/user/Picture s/wallpaper1.png Commented Oct 6, 2016 at 6:31
  • That works, thanks! Maybe you want to add this to your answer?
    – orschiro
    Commented Oct 6, 2016 at 7:10
  • After running your script and rebooting, my font settings have changed. Do you know how I can restore them?
    – orschiro
    Commented Oct 6, 2016 at 7:20
  • 2
    This also works for Ubuntu 16.04. Be careful about typos - I had a typo in the schema name within the .gschema.override file, which is the part between the brackets [ ], and as a result it was not properly loading. Once I fixed that I had the correct background.
    – jropella
    Commented May 9, 2017 at 8:49
4

It seems like all the gsettings have no effect in Ubuntu 15.10, (maybe because I installed Ubuntu Studio with xfce4 first).

I solved it by adding this line to /etc/lightdm/lightdm-gtk-greeter.conf:

background=/usr/share/backgrounds/Tranquil_by_Pat_David.jpg

or in one sudo command:

sudo su -c 'echo "background=/usr/share/backgrounds/Tranquil_by_Pat_David.jpg">>/etc/lightdm/lightdm-gtk-greeter.conf'
0

The non coder way is to use Ubuntu Tweak. Still available per the method listed in this answer.

0

Shotwell

For just the basic wallpaper changing feature, you don’t need to install any software, just shotwell.

Just launch the pre-installed Shotwell photo manager, choose the pictures you need (you may need to import them first), then go to Files -> Set as Desktop Slideshow. Click "on lockscreen".

Finally set the time interval in next dialog as desired and done!

source: http://ubuntuhandbook.org/index.php/2018/07/4-wallpaper-changer-ubuntu-18-04/

Note: This does not work for the login screen any more in Ubuntu 19.04, but still for the dektop background.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .