1

Here is my OS details:

$ uname -a
Linux starbuck 3.2.0-92-generic #131-Ubuntu SMP Tue Oct 20 16:16:02 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Here is my R version:

$ R --version
R version 3.2.2 (2015-08-14) -- "Fire Safety"

Here is my .Rprofile:

options("repos" = c(CRAN = "https://cran.r-project.org"))

Now when I open R and try to list the available packages I get:

 > available.packages()
 Warning: unable to access index for repository https://cran.r-project.org/src/contrib
 Package Version Priority Depends Imports LinkingTo Suggests Enhances
 License License_is_FOSS License_restricts_use OS_type Archs MD5sum
 NeedsCompilation File Repository 
  • Works without any problems here. Please try it again. And add the output of lsb_release -a to your question. – A.B. Nov 5 '15 at 8:19
  • I had installed the package from cran.r-project.org/bin/linux/ubuntu. Apparently, this package did not/does not build with libcurl (as capabilities('libcurl') returns FALSE). Thus, I cannot hit HTTPS CRAN sources. My next question then is, how can I install R with libcurl support? – mikeycgto Nov 5 '15 at 15:49
  • @mikeycgto it seems you did get an answer from the R-sig-Debian mail list. Care to add it as an answer here? – amc Jun 14 '16 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.