I know the Surface Pro 4 is new, but has anyone tried to support the keyboard and mouse pad for it? None of the input devices (screen, key/mouspad, stylus) appear to work when I load the live USB. I'd be willing to try my hand and creating something to support these devices, but I would need someone to point me towards reference material where I could teach myself about drivers.


Here was my solution, which worked using Ubuntu 14.04 LTS. Took me 1.5 days to figure out :-/

I could not do this without a multi USB adapter. I needed at least 2 USB ports. Here's what I did.

  1. Plug the multi USB adapter in.
  2. Plug the wireless keyboard & mouse dongle.
  3. Load Windows 10 and shrink the C drive so that you have enough room for a Ubuntu partition and a swap drive (note that Windows will prevent you from doing this, so you need to follow instructions here)
  4. Create two new partitions: one for Ubuntu and one for swap - swap doesn't have to be huge. I use a couple of Gig, but I don't think you even need that to be honest.
  5. When you turn on the SP4, hold down the + volume button until the UEFI screen appears.
  6. Disable Secure Boot and TPM.
  7. Make sure USB Storage appears at the top of the list in Boot config.
  8. Boot up Windows, open a command prompt as Administrator and type bcdedit /set {bootmgr} displaybootmenu yes and hit enter. This will make sure the Windows Boot menu appears on turning on the SP4 - note this also gives you many more boot options, so can be very useful.
  9. Now put your Ubuntu Live USB in and reboot and install Ubuntu from the USB stick (your wifi/bluetooth USB and mouse will hopefully work - mine did but only with the multi USB adapter). Note that if "Install alongside windows" is missing, then click "Something else" instead. You need to assign ext4 root (/) partition, swap partition, and also select the Windows Boot Loader partition as the Ubuntu EFI partition. Do NOT format the EFI partition !!!

When I rebooted, the Ubuntu GRUB2 loads up and gives you the choice to either load Ubuntu, or open the Windows Boot Loader.

Note - it may not actually be necessary to enable the Windows Boot Loader menu, but it didn't work when disabled for 15.10.

If anything goes wrong you can always download an SP4 Windows 10 Recovery ISO from Microsoft's website, and there's always the recovery partition on the SP4. Overall I'd recommend turning on the Windows Boot Loader menu as it gives you more boot options.

Anyway, good luck !

| improve this answer | |
  • 1
    Does Secure Boot really not work? It's a Microsoft device, Ubuntu's Bootloaders are signed with a Microsoft key (UEFI third-party) that should be included unless the Surface devices diverge from the typical setup. – LiveWireBT Jan 19 '16 at 15:20
  • I'm not sure TBH. I have some questions remaining of my own as I switched from 15.10 install to 14.04 at some point during the above. But since 14.04 installed and worked after much frustration with 15.10, I did not have the time or desire to find out which bits worked/didn't work for 14.04 and 15.10. In response to your question, I would try installing 14.04 as you would normally, but if that doesn't work use my instructions. Then again, even if installing 14.04 the standard way you'll still need multi-USB, keyboard/mouse, and drive shrinking which my answer can hopefully help with. – Pixel Jan 19 '16 at 15:46
  • 1
    PS Maybe you can turn secure boot and TPM back on after the install, but I haven't tried that yet. – Pixel Jan 19 '16 at 15:47
  • PS out of interest there is a second USB port on the power adapter of the SP4 ! - but alas this only charges; no data :-( – Pixel May 9 '16 at 21:19

For me, those things are not running on my SP4 HD installation (with kernel 4.2.0-21 and SP3 drivers):

  • Cover (Keyboard and Touchpad)
  • Hardware buttons
  • Stylus and any touch input

Bluetooth and Wifi are running fine. If you look around you find a few patches that bring the SP4 cover to work but you have to build your own kernel currently. In a few weeks all this things are hopefully included in the main kernel. So you better wait for this.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.