4

So I have a new computer and a new Ubuntu install on a partition (Inspiron 13 7000, intel i3, Windows 10 and Ubuntu 15.10) It works great..... Except for this really annoying little bug involving the boot-loader. I can't get Windows to show up in GRUB, I've tried about 20 different variations of a custom entry in 40_custom and all of them throw the error that the partition could not be found. EDIT: I've also tried running the boot repair tool to no avail.

For a while I was completely locked out of windows because of this. I eventually managed to get back onto the windows side by entering setup and disabling legacy boot and enabling "safe boot" (whatever that is?). Of course now, GRUB doesn't show up and I can only access windows.

I can get back to Ubuntu by reversing those changes and rebooting, its just a pain to do every time I want to switch OS. On my old computer, Windows showed up in GRUB automatically and I could simply select the right OS at every boot. On that one I was using 14.04 which perhaps is the answer to the problem? I initially went for 14.04 but my wifi card wasn't recognized so someone on here suggested I switch to 15.10 which solved the wifi issue but then mucked up the bootloader situation.

Is there any way to fix this?

Thank you!

5

It sounds like you accidentally installed Ubuntu in CSM or "Legacy BIOS" mode.

To fix this, you're going to have to re-install GRUB from within Ubuntu.

First, install boot-repair:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update
sudo apt-get install boot-repair

Secondly, open boot-repair and go to the "Advanced Options." Within that, go to "GRUB Location."

From within this view, check the Separate /boot/efi partition button. Finally, click Apply.

Next, you must go back into the BIOS and disable Legacy Mode, but keep Secure Boot off.

When you reboot, GRUB should load and Windows should be detected.

(source)

1
  • 3
    Thanks! I ended up having to use boot-repair on a bootable USB because it wouldn't work from ubuntu in legacy mode and I couldn't access ubuntu out of legacy mode. The legacy mode thing was definitely the problem though! – Indigo Nov 5 '15 at 20:37
0

You can install boot-repair in your Ubuntu 15.10. Run in terminal :

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install boot-repair

Then, open boot-repair, choose Recommended Repair. It should fix your grub and Windows boot loader. Just follow the instruction after that.

1
  • Ah, my bad, I forgot to put that in my post, I did try that and it didn't have any effect on grub, but thank you! – Indigo Nov 5 '15 at 3:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.