2

i want to install libcairo2 (>= 1.12.0) on my 12.04 LTS. I need this package for monodevelop package. Any idea?

 rafael@rafael-note:~/Downloads/cairo-1.12.0$ sudo apt-get install
 monodevelop Reading package lists...Done 
 Building dependency tree    
 Reading state information... Done 
 Some packages could not be installed. This may mean that you have requested an impossible
 situation or if you are using the unstable distribution that some
 required packages have not yet been created or been moved out of
 Incoming. The following information may help to resolve the situation:

 The following packages have unmet dependencies:  monodevelop :
 Depends: libcairo2 (>= 1.12.0) but 1.10.2-6.1ubuntu3 is to be
 installed E: Unable to correct problems, you have held broken
 packages.
  • Edit your question and add the output of dpkg -l 'monodevelop*' | grep '^ii' – A.B. Nov 5 '15 at 7:31
2

monodevelop packages depend on libcairo2 version 1.12.0 or grater but Ubuntu 12.04 have 1.10.2-6 version (you can see here) so you have to manually download and install from here or here.

  wget http://archive.ubuntu.com/ubuntu/pool/main/c/cairo/libcairo2_1.14.2-1ubuntu1_amd64.deb
  sudo dpkg -i libcairo2_1.14.2-1ubuntu1_amd64.deb

download version according to your system configuration (64bit or 32bit ) if it still show any dependency then try command:

sudo apt-get install -f 
  • libcairo2 breaks libwebkitgtk-1.0-0 (<< 2.4.5-2~) -- cannot install on 12.04 – Bob Dylan Jun 27 '16 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.