0

Since I upgraded my system to 15.10 it freezes just after I type and validate the root partition password:

  1. EFI Boot
  2. Grub2 Panel
  3. System ask password for the root partition
  4. User type and press Enter
  5. System stops, without message, no disk activity

I tried all grub entry without any success (kernel 4.2 and 3.19, systemd, upstart and repair).

I can still mount my partitions from a live CD 15.10. Then I tried various fix with a chroot:

  • Add more dm-crypt relative module in /etc/initramfs-tools/modules file
  • Fix various iniramfs warning (like locale warning)
  • Launch update-grub and update-initramfs -u -k all without warning

Since it happens just after the root partition unkocking, there's no logs.


The configuration :

/dev/mapper/crypt_root on / type ext4 (rw,relatime,data=ordered)
/dev/mapper/crypt_home on /home type ext4 (rw,relatime,data=ordered)
/dev/sdb2 on /boot type ext4 (rw,relatime,stripe=4,data=ordered)
/dev/sda2 on /boot/efi type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=4039992k,nr_inodes=1009998,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=810576k,mode=755)

Cryptsetup:

/dev/mapper/crypt_root is active and is in use. 
  type:    LUKS1
  cipher:  aes-xts-plain64
  keysize: 512 bits
  device:  /dev/sdb3
  offset:  4096 sectors
  size:    491304960 sectors
  mode:    read/write
/dev/mapper/crypt_home is active and is in use.
  type:    LUKS1
  cipher:  aes-cbc-essiv:sha256
  keysize: 256 bits
  device:  /dev/sda7
  offset:  4096 sectors
  size:    1130182656 sectors
  mode:    read/write

/etc/initramfs-tools/modules

cryptoloop
aes
sha256
aes-x86_64
sha512-ssse3
dm-mod
dm-crypt

Update logs:

# update-initramfs -u -k all
update-initramfs: Generating /boot/initrd.img-4.2.0-17-generic
update-initramfs: Generating /boot/initrd.img-3.19.0-32-generic

# update-grub
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-4.2.0-17-generic
Found initrd image: /boot/initrd.img-4.2.0-17-generic
Found linux image: /boot/vmlinuz-3.19.0-32-generic
Found initrd image: /boot/initrd.img-3.19.0-32-generic
Found Windows Boot Manager on /dev/sda2@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
done

Bibliography:

1
0

The problem is fixed for me.

  1. boot on a live DVD
  2. mount the root partition and devices, then chroot
  3. reinstall lvm2 that was removed during the 15.10 upgrade
  4. remove all local diversions
  5. reinstall dmsetup to add a missing udev script in initramfs (55-dm.rules) => that cause this freeze
  6. reboot
1
  • great !! Could you please provide a more detailed step by step? Thanks, – Nik Nov 15 '15 at 0:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.