2

This question already has an answer here:

I suppose you will assume this question as a duplicate and probably will ban it, but believe me I tried almost everything I could find on this forum and beyond but nothing helped. Please help me with this weird problem, laptop is brand new. WiFi signal is very weak, even when I put it next to adapter, it disconnects after logout/sleep and needs reboot to reconnect. Tried following solutions: lfwinger/rtlwifi_new, rtl8723be.conf in /etc/modprobe.d/...but none of this solutions has any effect.

wlan0 IEEE 802.11bgn ESSID:"one13" 
Mode:Managed Frequency:2.467 GHz Access Point: 50:2E:5C:EE:D0:E1 
Bit Rate=72.2 Mb/s Tx-Power=20 dBm 
Retry short limit:7 RTS thr=2347 B Fragment thr:off Encryption key:off 
Power Management:off 
Link Quality=40/70 Signal level=-70 dBm 
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 
Tx excessive retries:0 Invalid misc:1088 Missed beacon:0

marked as duplicate by Pilot6, Eric Carvalho, user117103, David Foerster, Kevin Bowen May 10 '16 at 4:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Two items: 1) Is your laptop getting hot 2) can you tell me the output of iw reg get – Charles Green Nov 4 '15 at 16:50
  • thanks for reply. laptop temperature is ok. here is output: – my13 Nov 4 '15 at 16:55
  • country IN: DFS-JP (2402 - 2482 @ 40), (N/A, 20), (N/A) (5170 - 5250 @ 80), (N/A, 20), (N/A) (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS (5735 - 5835 @ 80), (N/A, 20), (N/A) – my13 Nov 4 '15 at 16:56
  • K - and can you append the output of iwconfig to your question? I think that your country code may be limiting the transmit power, which you are interpreting as a weak signal. – Charles Green Nov 4 '15 at 17:02
  • There is some information on the subject at this link – Charles Green Nov 4 '15 at 17:03