2

I have a macbook pro

MacBook Pro (Retina, 15-inch, Mid 2015)

2.8 GHz Intel Core i7

16 GB 1600 MHz DDR3

Intel Iris Pro 1536 MB

I have a separate partition for mac and ubuntu. Ubuntu is the main partition. it's about 250gig per partition.

I am currently running 15.10, but have had this issue on all the following versions 14.04, 14.10, 15.04 and current 15.10.

My swap partition is 32 gigs.

When I am in ubuntu and I go to settings and shut down, the system hangs on the splash screen. I must hard reboot the system. I have tried to ssh into the box and it is only possible after the reboot. Not when it is frozen.

The same thing happens when I just shut the lid of the laptop. However, after sometime, like the drive home from the coffee shop, the computer is humming and hot. So I immediately hard shut down.

I have been to irc and searched the web and found nothing that helps. If I can't get this to work, I'm going to have to learn how to use osx. Please help.

Thanks, Raif

6
  • 32gb is too much for swap. Make it 4, max 6. About shutdown, I will check it out. Nov 4, 2015 at 15:49
  • still suffering. still hating osx Nov 12, 2015 at 15:47
  • Seems like drivers are missing.. Did you install them, for chipset, graphics-card, etc. Nov 12, 2015 at 15:51
  • well, I'm fairly new to ubuntu/linux. I just installed the os. I'm not sure how to go about installing drivers for chipset, graphics-cards and whatever-else I might need. I don't dispute that my suffering is my own fault. Is there some where that shows all the drivers one would need for this and how to go about it?
    – Raif
    Nov 12, 2015 at 18:13
  • i've looked at help.ubuntu.com/community/MacBookPro. Mine is a 11,4 so I've tried the 11,1 and the 12,1 instructions. None of them mention anything about drivers except for setting up battery power management.
    – Raif
    Nov 12, 2015 at 18:59

1 Answer 1

0

If you use rEFInd to have a dual boot (Mac OS X, Ubuntu), you can choose to restart Ubuntu, rather than shut down it. Then, in the rEFInd screen (where you choose which OS to launch), you can choose to simply shut down the computer. It's a workaround, but it works for me...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.