3

I'm trying to upgrade my linode server from Ubuntu 15.04 to Ubuntu 15.10.

I run do-release-upgrade, and the script hangs here:

Checking package manager
Reading package lists... Done    
Building dependency tree          
Reading state information... Done
Building data structures... Done 

Calculating the changes

Calculating the changes

I've waited over 24 hours and it's still at the same place, and not using much CPU. Has anyone run into this problem, or does anyone know how to resolve it?

  • If it's still at calculating changes, you can terminate the process, it wont screw with your system and restart the process again. – We are Borg Nov 4 '15 at 15:49
  • I've tried restarting the process many times. It always hangs at this spot. – nnyby Nov 4 '15 at 15:56
  • 1
    Are you behind a proxy or something? And if this thing is failing, just use dist-upgrade from command line. – We are Borg Nov 4 '15 at 15:59
  • I'm not behind a proxy.. I'm using apt-get dist-upgrade now and it seems to be working. thanks. – nnyby Nov 4 '15 at 16:03
  • Cool. Good luck. Like I said, you just needed to restart. – We are Borg Nov 4 '15 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.