5

I have Ubuntu 15.10, running Gnome Retro/Flashback/Fallback... whatever it's being called right now. I also have Compiz.

When I play videos in either VLC or Gnome Media player, the screen frequently flashes green. Put another way, every now and again, the whole screen turns completely green, but just for one frame or so. Sometimes this happens multiple times within one second, other times it just happens once. The frequency of when this occurs is random, but I'd say on average as often as once every minute or so.

This seems to have started roughly when I upgraded to 15.10, though I can't say with absolute certainty that the upgrade was the dividing factor. Before around that time, video playback worked perfectly.

This only affects local video files I play. YouTube and other online videos seem to work fine.

I found some suggestions on the web for how to fix this. One was to open Compizconfig and check the box for "Force full screen redraws (buffer swap) on repaint". The other solution I tried was specific to VLC, and in preferences I unchecked the "Accelerated video output (Overlay)" box. Unfortunately, neither suggestion worked.

How can I eradicate green flickering from my videos?

  • This is a Graphics driver problem, which graphics card you have, even internal. – We are Borg Nov 4 '15 at 16:48
  • @WeareBorg, I have an Nvida graphics card. I'm not sure which one. – Questioner Nov 5 '15 at 4:37
  • Did you install graphics driver from softwares and updates? – We are Borg Nov 5 '15 at 8:21
  • @WeareBorg, I believe I have the latest Nvidia drivers installed. – Questioner Nov 6 '15 at 4:30
  • Did you checked it in Sofwares and updates and the restricted drivers section, post a screenshot please. – We are Borg Nov 6 '15 at 8:41
1

From settings video output to OpenGL or something other than you are currently using.

0

Hi it sounds like you are experiencing some codec issues I resolved the same problem by installing the restricted pack from ubuntu you can install it buy typing the following in the terminal

sudo apt-get install ubuntu-restricted-extras

Take note that it might be illegal in some country's

  • Thanks for responding. When I type that command, I get ubuntu-restricted-extras is already the newest version. – Questioner Nov 4 '15 at 15:57
0

I found that I needed to lower my post-processing setting in VLC. Disable it to see if you no longer get any green screen issues and then increase it incrementally to find the sweet spot.

0
  1. Open the Tools menu and select Preferences.
  2. Click on the Video tab and change the setting in Video - Deinterlacing to Off.
-1

1) The "green flashing screens" is a very old "de-interlacing" bug which has persisted in VLC player for years.

2) It is common to all hardware, drivers and operating systems, including windows.

3) Depending on whether the player starts by rendering odd or even frames, the flashing may (or may not) occur every time you play, start, rewind or fast forward a film.

4) The flashing is therefore intermittent, neither consistent nor repeatable.

5) It occurs in different movie segments at different times in the same file.

6) It happens only in certain movie files, most often in ripped DVD's, which contain multiple 1 GB files inside a VIDEO_TS folder.

7) It could also (therefore) be the result of incorrect HDCP decoding during the unauthorized DVD rips, using tools like "SlyFox anyDVD", such that the resulting (malformed) files confuse the de-interlacing algorithms in VLC player.

8) In all cases I have experienced, disabling video de-interlacing in VLC player seems to fix the problem, at the cost of jittery, poor video playback, with a low line count.

9) The problem does not seem to effect HD movies in single "Matroska" vid containers.

=== BTW: I wish people in forums stopped trying to sound smart, by flooding the forums with dumb "Generic" answers like: "Do you have the latest driver update?" ... or

"Is your mouse plugged in?" ... LOL.

Then 100,000 other web sites scrape and reprint these IDIOTIC statements and reprint them as their own, flooding the Internet

with worthless spam.

Empty cans need to stop making so much noise!

===

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.