2

I am trying to select xfce desktop environment upon boot up with autologin enabled. I created a config file in /etc/lightdm/lightdm.conf.d/50-myconfig.conf with the settings as below:

[SeatDefaults]
user-session=xfce
autologin-user=user
autologin-user-timeout=0
autologin-session=xfce

But only the autologin takes effect, but not choosing the session. It will login into unity desktop environment.

However, if I try this on Ubuntu 15.10 Wily Werewolf, it works flawlessly.

FYI, these are the things that I have tried but doesn't seem to have any effect

  1. Set Session=xfce in ~/.drmc
  2. Modify ubuntu.desktop to start startxfce4, and even remove it temporarily from /usr/share/xsession

BTW. My lightdm version in Ubuntu 14.04.03 is 1.10.5, while Ubuntu 15.10 is 1.16.4

3
  • Why don't you try updating your lightdm Nov 4 '15 at 11:24
  • @dattutbrus I did try but it would say its already the latest. Doing apt-get install --reinstall would install the same version again.
    – Zaid
    Nov 4 '15 at 14:46
  • Then check if you have already installed all the XFCE desktop thingy. Also, check the autostart. If nothing's paranormal, try other display manager like gdm or try to turn off Autologin. Nov 5 '15 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.