24

I'm using Ubuntu 11.10 in a VirtualBox VM on a MacBook Pro with the default Unity UI. Positioning the mouse cursor over the 1-pixel wide border to resize a window is driving me absolutely nuts. Lots of people have asked the same question but all the advice I've found for fixing this doesn't seem to work:

  • In System Settings > Appearance, there are four themes (Ambiance, Radiance, HighContrast, HighContrastInverse), all of which have exactly the same size resize border.

  • Installing other packages (e.g. human-theme) has no effect on the theme selection.

  • My laptop doesn't have a middle mouse button, and even if it did, I don't want to use two hands to press Alt + middle button just to resize a window. In an attempt to change the resize key binding, I installed compizconfig-settings-manager and ran ccsm. Any changes I make to the Initiate Window Resize binding in the Resize window plugin have no effect. In fact ccsm seems to do nothing at all.

  • I discovered that the previous issue is because I'm using Unity 2D instead of Unity (3D), even though I'm picking the non-2D desktop when I log in. Unity 2D has no equivalent of ccsm as far as I can see. And when I configure VirtualBox so that the 3D Unity starts up, I get completely screwed up window behavior (missing all borders, don't accept mouse clicks, etc.). Sigh.

So:

  1. Help please!

  2. I hate to use the M word, but on the Mac all windows also have a 1-pixel visual border, but the invisible resize border is actually usable (it's at least 8 pixels wide on the edges, plus a nice big rectangle in the lower-right corner). I don't think implementing usable resize behavior should be up to each individual theme; this is a lower-level functionality issue and should work right in every theme. What's the right package to file a bug against for this?

4
  • Did you notice the triangle edge in the right lower corner of all windows using the gtk engine (which does not include stuff like chrome) that helps grabbing the window borders? Besides that, on my desktop (Full-HD monitor, 23 inch) it seems to be also at least 8 pixels that are grabable (whats the word for that? lol) on every side except the upper one. Is this not the case with you?
    – Dominik
    Oct 19, 2011 at 17:43
  • 1
    I'm not sure what you mean by windows using the gtk engine--when I open Terminal or Home Folder I don't see any triangle edge in the lower right corner.
    – eswierk
    Oct 19, 2011 at 18:06
  • I am sorry, you are right - it used to be in 11.04 or 10.10 i think, but they seem to be gone.
    – Dominik
    Oct 20, 2011 at 14:22
  • I saw somewhere that this was a last-minute downgrade to avoid a bug in some package. If this is the case, all you can do is wait, or try a different window manager. Oct 24, 2011 at 19:43

7 Answers 7

9

To make the window borders bigger you can follow the instructions in comment 8 of the above mentioned bug:

Colin Law (colin-law) wrote on 2012-01-31: Re: Difficult to grab window borders in unity-2d

Another workaround is to hack the theme itself. For the Ambiance theme edit /usr/share/themes/Ambiance/metacity-1/metacity-theme-1.xml and in the section starting <frame_geometry name="frame_geometry_normal" change left_width, right_width and bottom_height from 1 to 3.

But instead of changing the width from 1 to 3, I changed to 8px, because I think 3 is still too small. To make the changes take effect, change to another theme and then back again.

6

This is an open issue on launchpad.net: https://bugs.launchpad.net/ubuntu/+source/unity-2d/+bug/878198 . Please add yourself, maybe someone will take notice.

2

I did learn (and I had borderless windows with no min max close icons) that holding down Alt and choosing a blank area inside a window allows you to grab and move the unmaximised window around.

With Chrome carefully try and find a clear area in the tabs bar - right click and deselect Use System Title Bar and borders

0

You can enable the Unity Grab Handles for easier window handling:

Install the Compiz Settings Manager (ignore if it's already installed)

sudo apt-get install compizconfig-settings-manager

Bring your run dialog and type

ccsm

The Compiz Settings Manager will open.

In the search box, type "png" and tick the PNG image loader checkbox.
Now search for "grab handles" and tick the box next to the Grab Handles item.

Now click the item itself; a new screen will appear.

Click in the button at the right of the "Toggle Handles" and pick your hotkey to toggle the handles.

0

I don't know how to do what you're asking or if it's possible.

Here, I think, is fair a compromise if the conditions are just (1) hitting a bigger resize target and (2) doing it with one hand with a mouse/touchpad: Right-click the title bar of the window and click "Resize."

I still often forget that that's there when I, myself, struggle with the thin borders.

0

The quick and ugly way to fix it would be setting the resolution to something ridiculously low for a high density display, i.e. 1366x768. This only makes sense if you don't need a permanent solution, for example when booting from a live cd.

To make window decorations more usable without changing resolution you would need to set double font scaling and set a window manager theme which was made for retina displays.

Xubuntu

This is what worked for xubuntu 16.04 to make it partially usable on a macbookpro:

  1. Under Settings > Appearance Fonts tab set Custom DPI setting to 200 or higher.
  2. Under Settings > Window Manager Style select Default-xhdpi.

Ubuntu

For Ubuntu Unity you would need the gnome-tweak-tool which can be installed with:

sudo apt install gnome-tweak-tool

Once you launch gnome-tweak-tool go to Windows and under the HiDPI section set the Window scaling to 2.

Hint: Search for High DPI window manager themes for your desktop and you might find something that works better than ootb themes.

Support for High DPI screens is still not perfect on linux, but apparently Gnome and Ubuntu are working on improving it.

0

No need to do all this alteration if you install Compiz Window Manager, Compiz Fusion Icon and the Emerald Theme Manager. I usually install Synaptic package manager if it's not installed by default and then search for all Compiz stuff to install and install the Emerald Theme Manager through Synaptic also. Emerald is described as a theme decorator for Compiz. If you use Ubuntu-Mate there is an option to make Compiz Mate compatible in the Compiz Config Settings Manager. The same goes for Gnome. You need to add Compiz to your program start-up list so that the Window manager loads every time your system starts. I also add Emerald and the Fusion Icon. The Fusion Icon appears in the panel ready for you to alter any settings whenever you want. I've not had any problems with Compiz in many years of use but others have. I think it depends a lot on the graphics manager. Especially if you like eye-candy and rotating cubes to select desktops quickly and with a nice effect. Anyways, I use a theme that has Extra Mouse Grabs as an option in 'Edit Themes' once you have selected a theme that you like. I don't believe all themes will have this option, you will have to check. It does depend upon the theme creator and what they have added. Once in 'Extra Mouse Grabs' simply adjust the size. I went for four on all sides. Originally the theme I chose had no side or corner grabs but upping the numbers from zero to four cured this. Good luck to anyone reading this. It has done the job for me and made life a lot easier. I was thinking I needed a new higher resolution mouse or something... Oh, and I enter the Mate Control Centre, Look and Feel, MATE Tweak, Windows and make sure that I have selected Compiz as the Window Manager to keep things tidy because Compiz will run on it's own but Marco will still be selected as the default manager in MATE Tweak and I don't want that. If you have any hiccups using your chosen Emerald Theme try another before binning the whole idea.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .