1

I have the issue of "Unable to connect to core client" that others have had in the past and their solutions are not working.

I do not have a firewall running.

The suggestion here has already been carried out by the install script:

https://wiki.archlinux.org/index.php/BOINC#Using_BOINC

Apparently the BOINC client is running but this is not reflected in the output of nmap localhost.

Nothing works.

Running Ubuntu 14.04.3 LTS, BOINC version is 7.2.42 i686-pc-linux-gnu.

  • Have you solved your issue? – user123456 Oct 8 '16 at 18:16
  • I uninstalled BOINC and have been using F@H since then. I'll let you know what happens if I attempt to test it now. – readyready15728 Oct 10 '16 at 1:33
  • Since I did this uninstall, Ubuntu has a package prepared for BOINC, which is effective. I will accept your answer though I have no way to verify this is my only option anymore. – readyready15728 Oct 10 '16 at 1:37
3

Use the terminal:

sudo boinc --dir /var/lib/boinc-client

If the project is not attached yet, run:

sudo boinc --dir /var/lib/boinc-client --attach_project [URL] [KEY]

Where [URL] can be found in the project list and [KEY] is given by logging in in project site or by running after registration:

sudo boinc --daemon
sudo boinccmd --lookup_account [URL] [MAIL] [PASSWORD]

For instance, formilkyway@home, I run BOINC with:

sudo boinc --dir /var/lib/boinc-client http://milkyway.cs.rpi.edu/milkyway 6c2b64e6238a1223e3a4f8db56eabb3d

where my key is obtained using:

sudo boinc --daemon
sudo boinccmd --lookup_account http://milkyway.cs.rpi.edu/milkyway/ mymail@address.com mypassword

mymail@adress.com may be replaced by the username for certain project (including the worldcommunitygrid )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.