1

I'm using Lubuntu 15.10 and I have installed Chromium version 45.0.2454.101.

Use "make Chromium the default browser" not works (I not see any error).

The usual solution in Ubuntu is to open "Preferred Applications" - but I don't have that option on Lubuntu.

I have also tried update-alternatives.

There is only one alternative in link group x-www-browser (providing      
/usr/bin/x-www-browser): /usr/bin/chromium-browser
Nothing to configure.

Any other ideas?


Updated with more info

Type asociations looks fine

$ xdg-mime query default text/html
chromium-browser.desktop

Running $ chromium-browser on the console I see the following error each time that I click on "make Chromiun the default browser"

xdg-settings: unknown desktop environment
  • Running from the console I can see the error when I try to set it as default "xdg-settings: unknown desktop environment". – Carlos Garces Nov 3 '15 at 21:42
  • 1
    Do you see "Default Applications for LXSession" in the menu under preferences? That's where you change that. – KGIII Nov 3 '15 at 22:16
  • Already changed "Default Applications for LXSession", (was x-www-browser)no effect. – Carlos Garces Nov 4 '15 at 22:49
  • We're going to have to do it the hard way. I'll post an answer in a minute. – KGIII Nov 4 '15 at 23:04
0

This is a known bug for Ubuntu 15.10. See the bug report here.

1

You can try: Default application for LXSession -> then select the default web browser.

Also for html files, you can right click on any .html file and set the open with option to chromium. From there on, the default application for all html files would be chromium.

1

I was hoping that we could do this the easy way. It doesn't appear possible but it's still pretty easy. I'll try to shorten it so you can mostly cut and paste.

  • Open the terminal with CTRL+ALT+T.
  • Enter the following: gksudo leafpad ./.config/mimeapps.list
  • Press ENTER.
  • Enter your password.
  • Find this line: text/html=opera-beta.desktop (It will not say Opera for you).
  • Change that line to text/html=chromium-stable (assuming stable build - else beta, I think).
  • Press CTRL+S to save the document and close it.

    Now you might have to reboot or logout for it to take effect. I also have no idea if revisiting the Default Applications will revert it (you can check) but it shouldn't.

    That should do the trick. If not then let me know and I'll go ahead and edit the answer to try one other way - assuming I can find it again. Do, please, let us know if it worked.

    • looks like my mimeapps.list is located at ~/.local/share/applications/mimeapps.list [Added Associations] text/html=chromium-browser.desktop [Default Applications] text/html=chromium-browser.desktop – Carlos Garces Nov 6 '15 at 0:16
    0

    Simple solution

    Works fine!

    sudo update-alternatives --config x-www-browser sudo xdg-mime default chromium-browser.desktop x-scheme-handler/http sudo xdg-mime default chromium-browser.desktop x-scheme-handler/https sudo xdg-mime default chromium-browser.desktop text/html

    Your Answer

    By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

    Not the answer you're looking for? Browse other questions tagged or ask your own question.