Possible Duplicate:
Are the Ralink RT3090 drivers incompatible with Ubuntu 10.10?

I have an issue with my wireless network,so that the connection is working for only a few minutes, after which my browser no longer is able to load pages, even if the wireless is still active/connected.

Furthermore, most of the time WPA2-personal protected networks don't work, (yesterday was the first time it worked - for a few minutes). By "don't work" I mean that it seems to successfully connect, but the browser can't load pages.

I am running Ubuntu 10.10 32bit, and my wireless card is a RaLink rt3090. No changes have been done to any settings since Ubuntu was installed - networking began working on its own after the installation - but as described in first paragraph not very well.

  • Unfortunately, the chipsets are different. – Pedro Oct 13 '10 at 20:46
  • 1
    I had the same problem because my SSID was hidden. If this is the case with your network too, switch it off. Apparently, it doesn't improve your wireless security, but it will occasionally break connections on Linux. :-/ – dr Hannibal Lecter Oct 13 '10 at 22:57

Have you tried to eliminate possible external factors? Check signal strength; sources of interference; alternative channel number.

  • I tried all except channel number. But I don't think it will work either. – Pedro Oct 14 '10 at 15:27
  • It is usually so trivial to change the channel number on your access point that it is well worth trying. It is advisable to choose a non-overlapping channel ie channels 1, 6 and 11 are good. – outofstep Oct 14 '10 at 17:02

We've already talked about this. Can you merge threads (questions) in stack exchange?

Are the Ralink RT3090 drivers incompatible with Ubuntu 10.10?

  • Merge threads? You mean copy my question as an answer to the linked thread or what? – Pedro Oct 14 '10 at 15:28
  • I suppose. I just didn't know if there's a way to prevent duplicate topics on this system. – xd1936 Oct 14 '10 at 16:15

I had the same issue in several computers running 10.10 with different wifi adapters. In the end, the conclusion is that network-manager-gnome has a bug causing the connection freeze. My solution was to use the package manager to remove "network-manager-gnome" and install "wicd". WICD is a network manager that doesn't have this annoying bug that canonical was not able to fix since 10.04.


this solution worked for me on ubuntu 10.10 on hp 4520s probook:

Go to your terminal and type in this command: lsmod | grep rt

Your output will lokk something similar to this one:

rt2860sta 488820 0 rt2800usb 37372 0 [...]

This gives the hint to the solution:

Steps to the solution:

open your Terminal and first type in this: sudo modprobe rf rt2800pci

Then afterwards type in this: sudo modprobe -rf rt2860sta

As the next step follows this command in your terminal: sudo modprobe rt2860sta

Just as you type in this, your networkmanager connects automaticly and comes back to work!!!

But to close the whole thing up, you need tot ype in this command, for finishing up:

echo blacklist rt2800pci | sudo tee -a /etc/modprobe.d/blacklist.conf

Not the answer you're looking for? Browse other questions tagged or ask your own question.