I recently purchased DWA 131 adapter. Its not working on ubuntu. I upgraded to 15.10 hoping that it would work ... but no link ..

Please help.

lsusb output is :

Bus 001 Device 002: ID 2001:3319 D-Link Corp.

dmesg output is :

[  691.728363] usb 1-3: new high-speed USB device number 2 using xhci_hcd
[  691.856817] usb 1-3: New USB device found, idVendor=2001, idProduct=3319
[  691.856822] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  691.856825] usb 1-3: Product: Wireless N Nano USB Adapter
[  691.856827] usb 1-3: Manufacturer: Realtek
[  691.856829] usb 1-3: SerialNumber: 00e04c000001

2 Answers 2


I packed this driver to a PPA with DKMS. It can be installed by

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtl8192eu-dkms

I do not support this driver for 4.8+ kernels. For those who are using Ubuntu with 4.8+ kernels I suggest installing it from github using DKMS by

sudo apt-get install git dkms
git clone https://github.com/Mange/rtl8192eu-linux-driver.git
sudo dkms add ./rtl8192eu-linux-driver
sudo dkms install rtl8192eu/1.0
  • it works too for: TP-LINK TL-WN823N(EU) "VER 2.0
    – gorlok
    Commented Sep 16, 2016 at 23:47
  • How can i use it for ver1.0? I tried to install it, the installation completed successfully, but the usb is not recognized (lsusb give me an empty line and the the green light is off)? btw - ubuntu 14.04 4.4.0-53-generic, TL-WN823N(EU)
    – Shai M.
    Commented Dec 10, 2016 at 17:11
  • I have no idea what v 1.0 is. Please ask a new question and post lsusb there.
    – Pilot6
    Commented Dec 10, 2016 at 17:18
  • Sorry, i misunderstood. I got the Ver 2.0 of the network stick. I got the same lsusb as here: askubuntu.com/questions/820886/…
    – Shai M.
    Commented Dec 10, 2016 at 17:30
  • With kernel 4.4 install the version for xenial. launchpad.net/~hanipouspilot/+archive/ubuntu/rtlwifi/+files/…
    – Pilot6
    Commented Dec 10, 2016 at 17:33

Try this - https://github.com/Mange/rtl8192eu-linux-driver

sudo apt-get install git build-essential
git clone https://github.com/Mange/rtl8192eu-linux-driver.git
cd rtl8192eu-linux-driver
sudo make
sudo make install
  • This worked ... I had to make a small change in the Make file because I got an error ... I added following line in make file : EXTRA_CFLAGS += -Wno-date-time Let me test it for few days ... if it works without issues, I will accept this as answer Commented Dec 10, 2015 at 14:30
  • This driver does not work in Raspberry Pi2. Kerner version 4.1.13 v7+ Says recipe for target module failed in Makefile line 1323 Any idea how to get it working on Raspbian ? Commented Dec 10, 2015 at 15:04
  • Incredibly, this worked here. I just installed a test lubuntu 14.04 box under Virtualbox/Vagrant and this started up withou a hitch - within the VM.
    – kert
    Commented Jan 10, 2016 at 6:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .