1

I've formatted the disk and installed Windows 7 on a pre-installed Windows 8. (UEFI - disabled secure boot) When I try to install Ubuntu from a live CD, it cant recognize my HDD partitions, not even trying to allocate a partition on ext4, NTFS in GParted live and on windows disc manager. Ubuntu simply can't see the HDD partitions nor the installation of windows, I tried to do something with fixparts but don't know exactly what to do. Here i put a screenshot. my partitions Edit: Here I list my partitions:

ubuntu@ubuntu:~$ sudo lsblk -f

NAME FSTYPE LABEL MOUNTPOINT

sda

├─sda1 ntfs Reservado pelo Sistema

├─sda2 ntfs

└─sda3 ext4

sdb
└─sdb1 vfat /cdrom

sr0
loop0 squashfs /rofs

ubuntu@ubuntu:~$ sudo lsblk -l

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT

sda 8:0 0 465.8G 0 disk

sda1 8:1 0 100M 0 part

sda2 8:2 0 97.6G 0 part

sda3 8:3 0 368.1G 0 part

sdb 8:16 0 3.7G 0 disk

sdb1 8:17 0 3.7G 0 part /cdrom

sr0 11:0 1 1024M 0 rom

loop0 7:0 0 962.1M 1 loop /rofs

Ubuntu's Gparted give me a warning when opened:

/dev/sda contains GPT signatures indicating that it has a GPT table. However, it has a fake msdos partition table as it should. Perhaps it was corrupted? Is this a GPT partition table?

  • Please start the Ubuntu live system and provide the output of sudo lsblk -f and sudo fdisk -l. A screenshot of GParted might help too. If your hard drive(s) aren't listed there at all, provide the output of sudo dmesg. You can copy and paste command output on the terminal. Please edit your question, if you want to add information. Especially file or program output listings (with the help of the {} button in the editor toolbar) are much more readable there and overall it's best to have everything relevant in one place. – David Foerster Nov 3 '15 at 15:33
  • 2
0

Make sure to boot the LiveCD in no-EFI mode, since you've installed Windows in legacy mode.

Execute sudo gdisk /dev/sda and try converting to MBR and then rewriting the partion table under Recovery/transformation options.

| improve this answer | |
  • Solved! Thank you! Now Im going to test the boot. – Dennis Nov 5 '15 at 12:35
  • 1
    I've got new problems with the boot, updated grub and it doesn't worked to enter windows. I rebooted and recovered windows with the boot disk, and finally it worked! Thanks a lot! – Dennis Nov 5 '15 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.