1

I just recently bought myself a Dell Inspiron 7559 and, of course, installed Ubuntu on my second SSD. Had to start up the installation disk with nomodeset as it wouldn't get past the loading screen. After installing the OS everything seemed to be running pretty decently until I tried installing the proprietary Nvidia drivers for my GTX 960M GPU.

I've reinstalled the OS 3 times after hosing the graphic settings to the point where X refuses to even load trying to fix the issue. Once I've installed the stable version of the proprietary driver in Settings -> Software & Updates -> Additional Drivers my laptop refuses to get past the login screen. It will appear as if it's loading, flash an fsck message on the screen for a fraction of a second, and then go right back to the login screen ad infinitum....

To cap things off, when the laptop 'is' working and isn't using the proprietary drivers the screen won't wake up from sleeping if I close and open the lid, though I'm thinking this issue also stems from the lack of a proper graphics driver.

How would I begin to resolve this issue?

0

I don't have enough rep to comment. I got Xubuntu 15.10 working on my Inspiron 15 7559 with functional suspend mode and the ability to switch between integrated and discrete graphics.

See my answer here: - Graphics and sleep issues on Dell Inspiron 15 UHD

Another similar question: - Packages of graphic card driver for GeForce GTX 960M by Ubuntu 14.04

Edit: Removed duplicate content. I learned it is bad practice to post duplicate answers to related questions.

  • Thank you so much!!! This not only fixed my issue but it works just as well with Ubuntu 15.10. Drivers are installed perfectly! – Paul Molina Mar 31 '16 at 18:59
1

I had similar issue with my laptop which was having Nvidia GTX 950M(almost close to what you have). My advice even if the proprietary Nvidia drivers might perform better - it's better to stick to the opensource versions as they seems to be more compatible(at least in my case for 2 machines during the last 6 months)

Here are the steps

Generally you should use the drivers from the official Ubuntu repositories. Because you are having problems, using the latest drivers might be better. Install the latest official stable NVIDIA drivers for the GEFORCE GTX 960M.

Based on this link you should install nvidia-361(which support GTX 960M). M is the mobile varient - on desktops you will find no M at the end of the model.

First uninstall the currently installed NVIDIA drivers.Boot the computer, when the GRUB menu appears ...

Highlight the Ubuntu menu entry and press the E key.Add nouveau.modeset=0 to the end of the linux line. Press F10 to boot the Ubuntu operating system.

When the login screen appears press Ctrl+Alt+F1.Enter your user name and the password, then execute :

sudo apt-get purge nvidia*  
sudo reboot  

Now install the latest official stable NVIDIA drivers.Boot the computer, when the GRUB menu appears ...

Highlight the Ubuntu menu entry and press the E key.Add nouveau.modeset=0 to the end of the linux line. Press F10 to boot the Ubuntu operating system.

When the login screen appears press Ctrl+Alt+F1. Enter your user name and the password, then execute :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-361 nvidia-prime
sudo reboot  

Note : Maybe it is explicitly necessary to select the NVIDIA adapter in BIOS. When you want to use drivers 361, adding the PPA is not necessary. In this case the terminal commands you have to perform are these :

sudo apt-get update
sudo apt-get install nvidia-361
sudo reboot

In case you have installed the nvidia driver from their site then uninstall it as per that instructions.Uninstall that driver by running, as root, sh ./NVIDIA-Linux-x86_64-361.28.run and follow the on screen instructions.

Note : The solution I have provide has been tested on Ubuntu 14.04 LTS and Ubuntu 15.10 for two GPUs.

0

To solve your problem install the very latest current stable NVIDIA drivers 355 !

But first uninstall every NVIDIA related software you have had installed before.

When login screen appears press Ctrl + Alt + F1

Enter user name and password and then execute:

sudo apt-get purge nvidia*  
sudo reboot

Now install the new drivers - repeat the procedure ...

When login screen appears press Ctrl + Alt + F1

Enter user name and password and then execute:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-355 nvidia-prime
sudo reboot  

Note : Use NVIDIA X Server Settings -> Prime Profiles to switch graphics cards.

  • Still getting an infinite loop after doing this :( Checked my syslog file and "ureadahead:/: Ignored relative path" is there for like, several thousand lines. – Paul Molina Nov 4 '15 at 5:07
  • Still getting an infinite loop after doing this :( Checked my syslog file and ureadahead:/: Ignored relative path is there for like, several thousand lines. Don't know if that has anything to do with it~ – Paul Molina Nov 4 '15 at 13:06
  • @PaulMolina : Did you ever have installed bumblebee before ? – cl-netbox Nov 4 '15 at 13:08
  • @ cl-netbox: Nope. I had just reinstalled a fresh copy of the OS before I performed your instructions. – Paul Molina Nov 4 '15 at 17:33
0

Although this is part of your problem, I could ever solve the problem

and then go right back to the login screen ad infinitum....

by this way.

Press Ctr + Alt + F1 and go into the console screen.

Next, remove .Xauthority file.

$ rm ~/.Xauthority
  • How does removing that file helps. It actually indicates that your unity-session is finally killed or terminated. – We are Borg Nov 3 '15 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.