0

My computer has aquired some problems after upgrading to Kubuntu 15.10 from 15.04:

  1. It restarts when I shut it down, which makes it impossible to shut it down.

  2. The resolution of the external monitors is too low.

I have noticed the following error message that shows up every time I start or shuts down the computer:

drm:intel_pipe_config_compare [i915]] *error* mismatch in ips_enabled

What does that mean? Are the problems related to this error message? and how do I fix it?

  • The first question is going to need more info to find a solution. Switch to a TTY terminal (Ctr+Alt+F1), log in, and run the command "sudo shutdown now". This should tell you if there's a problem shutting down. If there isn't, then something else is causing your reboot. – SuperSluether Nov 3 '15 at 2:19
  • @SuperSluether I did as you said. It shut down in precisely the same way as on a "normal" shut down. The error message in my post showed for a split second and then the splash screen with "Kubuntu". It went black for one-two seconds then restarted. – MunHo Nov 3 '15 at 14:34
0

I can answer your last question. It's a kernel bug with the Intel graphics: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1492764

Some people reported it as fixed in Linux Kernel 4.3, but it wasn't verified as of this posting. If you think you need to, you can manually update to the new kernel: http://www.ubuntumaniac.com/2015/10/how-to-upgrade-to-linux-kernel-43-rc7.html

As for your resolution problem, a Google search and a couple bounces later, I found this: Can't set a higher screen resolution in a external display in a Dell Mini 10v laptop

It's old, but it might do the trick. Interestingly enough, the bug listings linked in the question are marked as Invalid and/or Won't Fix, and they're claimed as a bug with the driver instead of compiz. Possibly linked to your previous bug with the Intel graphics drivers? https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/830949

  • To update the kernel seems advanced. Is it advisable to manually update? or should I just wait until my packetmanager updates it for me? The link on the resolution tells me to use the xrandr command, through which I am able to set the resolution I want. But in the graphical System Settings interface, the wrong resolution is still shown (the pre-xrandr low resolution) and I am still not able to change resolution there. Thanks! – MunHo Nov 3 '15 at 14:44
  • Usually it's better to wait for things to update by themselves. If the error message isn't causing any problems, it's probably best to wait for the next kernel update. For the resolution issue, the comments on the linked question say to create an autostart script to change the resolution through xrandr on startup. That's the best solution AFAIK. Hopefully someone with more experience can help you with your shutdown problem and give a better solution for the other 2. – SuperSluether Nov 3 '15 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.