3

I just upgraded to Ubuntu 15.10. I am still using the latest NVIDIA binary driver 352.41 from nvidia-352 w/ GT730 card.

When I start spyder and spyder3, the display is garbled with window elements wrongly sized and out of place. I get the following error:

$ spyder
QNativeImage: Unable to attach to shared memory segment. 
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x0

. . .

Can someone help me resolve this error?

Thank you in advance! -Bill

Here is a screen shot of the garbled spyder screen Here is a screen shot of the garbled spyder screen


Update Nov 3, 2015:

The problem is occurring with multiple applications: spyder, VirtualBox, and IPython Qt Console. It seems like the BadDrawable error may be related to Qt with Ubuntu 15.10.

Here is a screen shot of the garbled IPython 3 Qt Console screen Here is a screen shot of the garbled IPython 3 Qt Console screen

8

Have you tried the workaround described here? https://bbs.archlinux.org/viewtopic.php?id=200167

I had the similar problems with Skype, VLC and Double Commander on my laptop with Ubuntu 15.04 and the hack cured them all.

Just add the following line

QT_GRAPHICSSYSTEM=native

to the file

/etc/environment
  • Hi John, Thank you! Setting QT_GRAPHICSSYSTEM=native sems to work for Spyder. I will try it on the other programs I am having problems with and test it before I mark this as the answer. – Bill S Nov 5 '15 at 14:58
  • Was having same problem with mumble and this fixed it. But with fresh 15.10 install and intel drivers. – mp3foley Nov 5 '15 at 22:01
  • This answer works for me. I was having issues with skype, Krusader and smplayer. All of them seem to work fine now. – Zoltan Nov 6 '15 at 17:32
  • Although the graphics display looks better inside the programs, I think there is still something going on with 15.10. In MeshLab, I am getting similar shared memory errors: (meshlab:5121): Gdk-WARNING **: shmget failed: error 28 (No space left on device) – Bill S Nov 6 '15 at 23:59
  • Maybe there is realдy little space on your drive?) Bill, if it woks, it would be fine to make description more general. I haven't seen a similar question related to Ubuntu 15.04. – John Matreshkin Nov 9 '15 at 8:11
1
QT_GRAPHICSSYSTEM=native  

works for me for VirtualBox.

  • Thanks again. QT_GRAPHICSSYSTEM=native seems to have fixed all the problems with programs I am using so far (it has only been a week since upgrade): MeshLab, IPython, Spyder, etc. – Bill S Nov 6 '15 at 23:54

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.