3

I'm currently using Ubuntu 15.10, but I had the same exact problem with 15.04. I experience a tearing while doing pretty much anything: it ranges from barely noticeable when watching a film with VLC to annoying when browsing or watching a video with Firefox, and it's god awful when using Chrome (which is currently the only way I have of using Netflix). Oddly enough, when I play this game it suffers from little tearing. Thanks in advance for your help. I tried fixing this issue once and I only managed to mess up my former installation of Ubuntu.

EDIT: I forgot to mention that this happens both with with the recommended nVidia driver and with the default open-source one; the latter seem to do a teeny tiny bit better, but I might be mistaken.

0

Could it be that you are using the XFCE (Xubuntu) or LXDE (Lubuntu) desktop environments?

Their compositors have common tearing problems with newer Nvidia video cards. If this is the case, try disabling the native compositor and install "Compton" or "Compiz" instead. This should solve the tearing.

If this is not the solution, try setting the "PowerMizer" option to Maximum Performance in the Nvidia settings and see if this changes anything, also make sure that VSync is enabled there.

  • No, I'm currently using Unity. – random_human_being_ Nov 3 '15 at 13:22
  • I'll try Maximum Performance however I can't find the option to enable VSync. I've been looking for 5 minutes and didn't find anything VSync-related. – random_human_being_ Nov 3 '15 at 13:24
  • I'm sorry, I meant "Sync to vblank". That's just a function that is often mentioned in context with screen tearing, but I can't tell if it will work for you. Did you have any success in the mean time? – Prototype700 Nov 4 '15 at 2:08
  • I'll look for that as soon as I can. – random_human_being_ Nov 4 '15 at 19:02
0

So, I found a workaround... well, sort of: I opened nvidia-settings and enabled my integrated Intel card, and according to this test the tearing seems to be gone. It kind of bugs me that I've wasted money on a gpu with a shitty driver, but I guess that form now I'll have to settle for what I have. If someone has any better suggestion please let me know.

EDIT: even with the integrated gpu chrome has some serious tearing. Everything else works alright.

0

Duplicate

Two steps that solved the problem for me on my gtx 960 on Kubuntu 14.04

1st try adding this to your xorg.conf file @ /etc/X11/

Section "Screen"

Option "metamodes" "nvidia-auto-select +0+0 {ForceFullComposition = On}"

If that works only sometimes or distorts clarity on internet or game video then add this and it should make a big difference and hopefully permanent fix.

Section "Screen"

Option "TripleBuffer" "1"


You can check out my research here-askubuntu.

  • It didn't seem to do much. – random_human_being_ Nov 28 '15 at 14:24
  • Please update/edit your post to show everything you've tried so far, couldn't find, results. – boydo Nov 29 '15 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.