13

I've just installed Ubuntu Server 11.10 and the tilde (~) and double quotes (") keys don't do anything - they don't print to the screen. I'm only using the command line (no GUI) and many tutorials say to use setxkbmap and xmodmap which aren't working for me.

7 Answers 7

30

Check your keyboard layout settings, make sure it's English (US) not English (US, international with dead keys) (assuming you're using US keyboard).

To change it from the command line, enter the following:

$ setxkbmap -layout us

It worked for me.

1
  • Sorry about not getting back too soon. I solved the problem via installing/running console-setup and changing the layout from there.
    – sagaci
    Nov 27, 2011 at 14:41
2

For those not using XWindows, e.g. Ubuntu server, setxkbmap won't work. Use

sudo apt-get install console-common

Or if it is already installed:

sudo dpkg-reconfigure console-data

Follow the instructions to set the keyboard, e.g. for me, "pc / qwerty / US american / Standard / Standard".

Original source is here

1
  • WARNING: If you are using Xubuntu and installing this console-common it will also remove the xubuntu-desktop package. On the next day when you boot your laptop and you will only see a blank screen and nothing happen..I install again xubuntu-desktop and it works.. I just realize that the console-common is the culprit. Sep 9, 2017 at 8:49
0

If you're using an international keyboard, try English US, with the variant English (international AltGr dead keys), this worked for me. (Whereas US, alternative international and US, international with dead keys did not work).

0

You can change the keyboard in the Ubuntu System Settings, Text Entry. Remove the English(UK) from 'Input sources to use:' by selecting it in the list and clicking '-'. (Tested in ubuntu 14.04)

http://www.wikihow.com/Change-Keyboard-Layout-in-Ubuntu

0

For US English, To change it from the command line, enter the following:

$ loadkeys us

It worked for me.

0

I also had the same issue..but fixed it using methods below -

  • Permanent Solution: In a Linux dist. OS use the following keyboard layout - "English(US,with euro on 5)"

  • Temporary Solution: use the following key combination - 'Alt' + 'Shift' + " "

    or 'Alt' + ' '

Hopefully. this will solve your problem.. :)

0

Be careful with a command $ setxkbmap -layout us because for instance in my case, my another keyboard input source (ukrainian) also switched into english, so I did not have kyrillic letters anymore.

So, my suggestion will be simply changing manually 'English (US, alt. intl.)' into 'English (US)'.


References:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.