1

I have a freshly installed Ubuntu 14.04 on a Dell E5450. The hard disk is fully encrypted on installation.

The laptop's keyboard is working fine, yet I have trouble when trying an external USB keyboard and mouse. They just won't work past the grub menu.

(I even have the feeling that USB isn't working at all post-grub.)

It's not a hardware issue, as the Live Stick will boot with keyboard and mouse support just fine.

Yet once I have to enter the passphrase to unlock the encrypted hard disk, I cannot type and even in Ubuntu itself it won't be recognized.

I've looked into this issue and found a bug report, yet none of the provided workaround seems working for me.

I tried adding these to my modules list:

$ cat /etc/initramfs-tools/modules
# List of modules that you want to include in your initramfs.
# They will be loaded at boot time in the order below.
#
# Syntax:  module_name [args ...]
#
# You must run update-initramfs(8) to effect this change.
#
# Examples:
#
# raid1
# sd_mod

hid
usbhid
hid_generic
ohci_pci

and running

sudo update-initramfs -u

Yet no luck.

How can I fix my USB for Ubuntu14.04 using full disk encryption?

0

This is only half the answer, as it solved the problem at hand, yet introduces another.

For the 3.19 kernel, one needs the linux-image extra:

Since I have the version 3.19.0-31 (see uname -a), I intalled it via:

sudo apt-get install linux-image-extra-3.19.0-31-generic

Then the USB starts working again after grub and makes my external keyboard work.

Yet it broke gdm and Ubuntu booted in low graphics mode, and gnome-shell won't start.

That's why I followed the how to fix low graphics mode, and the relevant part for me was the Intel driver:

For Intel it is recommended to do the following after doing all the steps mentioned above but before installing anything (When you are in the Terminal). You can choose Xorg-Edgers which is a PPA that brings many improvements, latest video drivers and more:

Warning: This PPA is very unstable for some things. So do it with that in mind.

sudo add-apt-repository ppa:xorg-edgers/ppa -y

After that sudo apt-get update and you should receive several updates. X-Swat currently does not have Intel drivers in the latest versions of Ubuntu.

I also reinstalled gdm and and after reboot, I finally had working system again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.