I've upgraded my Ubuntu installation from 11.04 to 11.10. If I choose gnome at the lightdm login screen the system logs me into a unity session. If I choose any other option the system logs me also into a unity session (I've installed fluxbox as well and it is not possible to start a fluxbox session). Does somebody has the same problem or could point me to the right log file to check for this problem?

  • Can you double check that it's gdm and not lightdm? lightdm is the default in 11.10 – Jorge Castro Oct 19 '11 at 14:21
  • I'm sorry, you are right. I edit the question. – user28975 Oct 19 '11 at 14:30
  • That is not really an answer since it leaves the 'original' problem unsolved. I switched from lightdm to gdm by sudo dpkg-reconfigure gdm which solved this issue for me. Unfortunately I'm not allow to post an answer to this question until 7 or 8 hours have passed. Argh. – user28975 Oct 19 '11 at 14:39
  • It's strange that the problem was fixed by changing display managers? What are the names of all the selectable session types listed in lightdm? What are the names of all the selectable session types listed in gdm? Generally speaking, to get a GNOME 3 session you would choose GNOME, and to get a GNOME 3 Failsafe session which is very similar to the non-Unity GNOME 2 interface that was available prior to Oneiric (called Ubuntu Classic), you would choose GNOME Classic (or GNOME Failsafe). – Eliah Kagan Oct 19 '11 at 14:41
  • Yeah. It's very strange. But both gdm as well as lightdm seem to offer the content of /usr/share/xsessions/ – user28975 Oct 19 '11 at 15:37

This fixed it for me:

sudo apt-get uninstall gdm
sudo dpkg-reconfigure lightdm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy