2

I am facing problems in dual-boot ubuntu and windows 10. Upon reboot system boots into windows rather than starting ubuntu grub. I tried to change the bootorder using efibootmgr. This was before changing the order-

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 3003,3000,3001,2001,2002,2003
Boot0000* Ubuntu
Boot0001* ubuntu
Boot0003* Windows Boot Manager
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot3000* Internal Hard Disk or Solid State Disk
Boot3001* Internal Hard Disk or Solid State Disk
Boot3003* Internal Hard Disk or Solid State Disk

I tried this command - sudo efibootmgr -o 0,1,3

This is the order after-

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001,0003
Boot0000* Ubuntu
Boot0001* ubuntu
Boot0003* Windows Boot Manager
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot3000* Internal Hard Disk or Solid State Disk
Boot3001* Internal Hard Disk or Solid State Disk
Boot3003* Internal Hard Disk or Solid State Disk

But when I reboot, boot order again reverses to the original one and therefore,windows opens by default. So, how can I change this boot order permanently.

1

First boot into your Windows installation and disable hibernation and Fast Boot.
Disable hibernation by opening command prompt as administrator and execute:

    powercfg /h off  

To disable Fast Boot open Control Panel (the old version - not the modern design),
select the Energy Settings, enable show hidden settings and uncheck Fast Boot.

Shut down the machine completely - do NOT reboot !

Reinstall the GRUB boot loader to your Ubuntu installation in EFI mode.
Boot from the Ubuntu installation media - open a terminal and execute:

    sudo mount /dev/sd*** /mnt
    sudo mount /dev/sd** /mnt/boot/efi
    for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
    sudo chroot /mnt
    grub-install /dev/sd*
    update-grub  

Note:

sd* = disk | sd** = efi partition | sd*** = system partition

To identify the partition numbers use GParted, the tool is included in the Ubuntu install media.
Boot into BIOS and select Ubuntu in UEFI settings to be the default operating system to boot.
Now you are able to select the operating system you want to boot from the GRUB boot menu.

| improve this answer | |
  • Ok what I understand is sd*** means the ext4 partition where my ubuntu is installed,, sd** is the boot partition but what is sd*? – Joker Nov 2 '15 at 15:54
  • @Joker : yes - and sd* is the "whole - main - disk" ... in most of the cases it is sda (the first disk). :) – cl-netbox Nov 2 '15 at 15:56
  • Sorry but it didnt work. Still system directly loads windows – Joker Nov 2 '15 at 16:05
  • @Joker : Please check again whether hibernation and fast boot is disabled - otherwise it will always boot into Windows ... and please check whether you can disable Intel Rapid Storage Technology in BIOS/UEFI settings - if not, disable it ! :) – cl-netbox Nov 2 '15 at 16:15
  • 1
    @Joker : You're welcome ! You nevertheless have to follow the instructions given in my answer ... disable hibernation and fast boot after installing Windows and then after that ... install Ubuntu ... so if you think this helped you can consider to accept the answer. :) – cl-netbox Nov 2 '15 at 17:09
0

I had the same issue when installing Ubuntu/Win7 dual boot. Rather than showing Grub, it skips straight into Windows. However, there was an easy solution for me: use Boot-Repair to fix Grub. The easiest way to use Boot-Repair is to boot into a live session of Ubuntu from a bootable CD or USB, and then install Boot-Repair and then run it. Reference here for how to do that. Changing the boot order probably won't work because Grub is not even being launched, which is the issue.

| improve this answer | |
  • Sorry but this is also not working – Joker Nov 2 '15 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.