5

Previous 15.04 version had an easy solution to change language on Caps Lock in System > Keyboard > Shortcuts > Typing

After update to 15.10 bind Caps Lock to 'Switch to next input source' is gone.

4

Gnome tweak tool GUI check:

Gnome tweak tool > typing > Caps Lock key behavior check Caps Lock is disabled.

Terminal:

gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['VoidSymbol']"

  • I've tried this on Ubuntu 16.04 with Gnome 3 and it doesn't work. – Cristiana Nicolae Aug 30 '16 at 7:15
  • 2
    @CristianaNicolae Answer above for the 15.10 version only. Ubuntu 16.04 with Gnome 3 just Settings > Typing > Modifiers-only switch to next source. – Kir Novak Nov 8 '16 at 1:21
  • 1
    Thank you very much! Now I've finally managed to solve my problem! Here are all the steps which I've done in Ubuntu 16.04: All Settings > Keyboard > Shortcuts tab> Typing > Modifiers-only switch to next source > click on Disable and choose, from the menu, the desired key combination (Ant+Shift). I've posted it for the benefit of other Ubuntu users. Thanks, once again! – Cristiana Nicolae Nov 8 '16 at 7:04

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.