1

I've upgraded from 14.10 to 15.04 and then directly to 15.10.

I have a TV connected to the computer via HDMI cable. The sound was working ok after the upgrade but after using the TV and coming back to the computer, I do not have the sound anymore.

Tried restarting the computer but no sound. When getting the logging screen, I do hear the sound though.

Looking into the settings->sound I only have the digital option and no analog option in the drop down menu.

Things I've tried:

sudo alsa force-reload

Killed the pulseaudio process and it restarted again automatically. Still no sound.

Reinstalled Alsa and Pulseaudio

$ sudo apt-get remove --purge alsa-base pulseaudio
$ sudo apt-get install alsa-base pulseaudio
$ sudo alsa force-reload

Restarted but no success. I also lost the volume icon in the top bar and the settings-sound looks a bit different now.

enter image description here

The device option did change though and now shows

HDMI / DisplayPort - built-in Audio

instead of just built-in Audio

Tried uninstalling Alsa and Pulse and reinstalling with the HDMI and TV not connected to the computer but got the same results.

Deleting the .config->pulse folder + logout, login didn't help

Here is the result of a $ aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 0: VT1708S Analog [VT1708S Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

card 0: MID [HDA Intel MID], device 3: VT1708S Digital [VT1708S Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

card 2: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

In the settings->sound profile, I only have

Digital Stereo (HDMI) Output

This is a screen shoot of the Alsamixer

enter image description here

Any ideas?

Thanks a lot

0

I'm answering my own question. I found out that the card profile is changing automatically to Digital each time I choose to use a different card (the one from the TV) and come back to the one of the computer. So, it come back to

Digital Stereo (HDMI) output

and I need to change it manually each time to

Analog Stereo Output (unplugged)

It is a bit strange to me because the Analog Stereo is marked as "unplugged" but it is working and I'm getting the sound back.

enter image description here

Tried to change the default profile of the card but no success so far. I will open another question about it

0

I have had similar problems and all the forums I could find were talking about PulseAudio and AlsaMixer. None of those solutions worked for me.

I finally found my solution in updating my Graphic Cards driver from which the HDMI cable was connected using these following steps: https://help.ubuntu.com/community/BinaryDriverHowto/AMD

You might not have the same graphic cards or any but you might give it a try to update your driver.

-1

Try in console, as normal user:

pacmd set-card-profile 0 output:analog-stereo

and reiniciate, after that analog stereo will be configurated

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.