13

For some reason I have graphical issues with Skype. I had less of them 3 days ago and thought that if I reboot pc everything will work fine. But it didn't hit the mark. While reinstalling Skype I can see such picture right now: enter image description here

I'm getting such error messages at console:

Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "unity-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"

(skype:17186): Gdk-WARNING **: shmget failed: error 28 (No space left on device)
4
  • 3
    A quick google suggests the Gdk-WARNING is because of too many open shared memory segments and suggests setting shmall, shmmni: serverfault.com/questions/373375/…
    – AJefferiss
    Commented Nov 2, 2015 at 9:10
  • @AJefferiss do you think I can have such issue if I never changed this config and it was working fine before? Commented Nov 2, 2015 at 9:44
  • 1
    in all honesty I don't know, it might be a sign that a recent update in some app caused it to not clear up shared memory segments but I'm just guessing. Take a look at the output of ipcs -m to see how many segments you've got setup at the moment. You can also run ipcs -mp to see the PID of the last process to attach to a segment.
    – AJefferiss
    Commented Nov 2, 2015 at 10:40
  • @AJefferiss you know, your comment helped, I will write my solution as an answer. Commented Nov 2, 2015 at 10:59

4 Answers 4

10

Got this problem with 2 simultaneous PyCharms running. So closing them is not a reasonable solution for me. Using raus81's advice edited skype dash link:

sudo gedit /usr/share/applications/skype.desktop

change

Exec=skype %U

to

Exec=env "QT_X11_NO_MITSHM=1" skype %U
1
  • Tested on ubuntu 14.04, and Skype 4.3.0.37 (multiarch, for ubuntu 12.04 on skype download page). And worked fine. Thanks for you and @raus81 Commented Nov 17, 2015 at 17:37
9

It's a QT related problem, I fixed running skype with QT_X11_NO_MITSHM=1

Start from shell:

QT_X11_NO_MITSHM=1 skype
2
  • Great solution, works like a charm, thanks @raus81 ;)
    – Hugo
    Commented Nov 20, 2015 at 9:54
  • I found this solved the same problem with other programs such as lyx. Commented Jan 22, 2016 at 18:29
6

As AJefferiss suggested I executed a command:

ipcs -mp

I found a "pid" of last process and executed:

ps aux | grep "pid"

It was PyCharm, I was running 2 instances of this IDE. After I disabled one of them, Skype issue was resolved.

4
  • Hey did you find any permanent solution to this problem? It appears again and again Commented Nov 3, 2015 at 11:58
  • I think you should reduce amount of loaded memory. It helps for me. Commented Nov 3, 2015 at 12:17
  • I am just a beginner, can you please tell me where to do that? Commented Nov 3, 2015 at 12:31
  • 1
    @RSB If you check internet, there are other problems and solutions. But this was helpful for me. ipcs -mp it will give you a long list of processes which use shared memory, the most right columns is process pid. It's a number, like 878. I took the last one row. After it, you can find process name for that pid. ps aux | grep 878. Mine was PyCharm. I just closed it and everything started to work as expected. Commented Nov 3, 2015 at 12:39
2

The reason for this is a bug in openjre-7u85: https://bugs.launchpad.net/ubuntu/+source/openjdk-7/+bug/1512760

According to the bug report there is someone working on this so it will be solved soon hopefully.

1
  • I have trapped in this issue on Debian with running Netbeans on openjdk-7 with version 7u85-2.6.1-5. With upgrading to 7u91-2.6.3-1 issue disappear. Thanks for link!
    – gavenkoa
    Commented Dec 1, 2015 at 18:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .