0

I installed "SuPHP" yesterday, and whenever, I am restarting "Apache", i am getting below error :-

 * Restarting web server apache2                                                                                                                              [fail] 
 * The apache2 configtest failed.
Output of config test was:
AH00526: Syntax error on line 15 of /etc/apache2/sites-enabled/000-default.conf:
Invalid command 'suPHP_UserGroup', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.

My File Content inside /etc/apache2/sites-enabled/000-default.conf is :-

<VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html
    <IfModule mod_suphp.c>
        <Directory /var/www/html>
            suPHP_UserGroup rocky rocky
        </Directory>
    </IfModule>

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Now, My Permission , User, and Group for "/var/www/html" is :-

root@rocky:/var/www# ll
total 12
drwxr-xr-x  3 rocky rocky 4096 Oct 29 05:38 ./
drwxr-xr-x 14 root  root  4096 Oct 29 05:38 ../
drwxr-xr-x  8 rocky rocky 4096 Nov  1 15:29 html/

Little information, that i would like to provide.

Earlier /var/www content were running under root, I changed owner id and Group id to my normal user group, i.e, rocky (user) and rocky (group).

So, that :- 1). I don't have to run or browse the directory as root user. 2). When browsing to http://localhost, I don't get Forbidden error. 3). I don't have to run my editor as root user.

What i have done ?

  1. I have already checked, the permission and folders, they are 755 and run by user and group rocky which is current user (i.e, me) - No Success
  2. I tried changing the directory back to root , user id and group id. - No Success
  3. I edited the suPHP_UserGroup rocky rocky to suPHP_UserGroup root root.

Am i missing anything, my webserver is not working, with below error. kindly help.

     * Restarting web server apache2                                                                                                                              [fail] 
     * The apache2 configtest failed.
    Output of config test was:
    AH00526: Syntax error on line 15 of /etc/apache2/sites-enabled/000-default.conf:
    Invalid command 'suPHP_UserGroup', perhaps misspelled or defined by a module not included in the server configuration
    Action 'configtest' failed.
    The Apache error log may have more information.

And Log says :- SoftException in Application.cpp:566: Directory "/var/www/html/" is writeable by group

Kindly Help. Thanks

0

Okay so to remove a user from a group use the following command in terminal

sudo deluser username group

then when adding a user to a group you use the following commands:

sudo usermod -a -G group username

I am not sure what you used to add and create your user as you don't specify in the question so remove the user and then recreate it with the commands I provided if that does not work please show us how you created your user.

Also you could try installing the gnome-system-tool to manage your users and groups visually like so:

sudo apt-get install gnome-system-tools
  • Yes, and i ate mango yesterday, It was delicious. Completely irrelevant answer. – HrithikRoshan Nov 2 '15 at 6:02
  • Hahaha lol then maybe you should phrase your questions better – RiaanV Nov 2 '15 at 6:03
  • Think, you could write better than that , "SoftException in Application.cpp:566: Directory “/var/www/html/” is writeable by group" , Ubuntu don't allow "root" user as login. There is 1 default user, which is "rocky" and it is not created, i didn't mention, i created user and failed. – HrithikRoshan Nov 2 '15 at 6:06
  • But the errors you are getting suggests that one or more folders have incorrect permission... That makes it globally writeable – RiaanV Nov 2 '15 at 6:08
  • Yes, and i have all set correctly, permission is 755 as suggested by suPHP . I am not sure, what is getting wrong. – HrithikRoshan Nov 2 '15 at 6:44
0

I got this fixed , by removing this irritating suPHP. I don't need anymore as it is taking more time to fix and has very less support.

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.