4

I'm new to Linux, currently using 14.04 lts. My laptop is a Clevo P150SMA (Sager P150SMA) with a Geforce GTX 970m, uses nvidia driver-352.55 I have tried every single installation that i saw here on this forum, also followed http://www.binarytides.com/install-nvidia-drivers-ubuntu-14-04/, And after all this and $ glxinfo | grep OpenGL | grep renderer I still get:

OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile

So i tried all this:

  1. sudo apt-get remove --purge nvidia-*

  2. Installing from the driver that you get from Nvidia page: NVIDIA-Linux-x86_64-352.55, didn't work.

  3. Software & Updates / Additional drivers / Tried to change it between 346, 352, 355 and X.org X server - Nouveau, didn't work.

  4. Installing Nvidia current driver from Ubuntu Software center, didn't work.

  5. Installing bumblebee, didn't work.

  6. Loads of tutorials here on the forum and youtube, didn't work.

All installations occurred normally and were done one at a time, not everything jammed in at once.

What i get from, $ lspci -vnn | grep -i VGA -A 12

00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
    Subsystem: CLEVO/KAPOK Computer Device [1558:5281]
    Flags: bus master, fast devsel, latency 0, IRQ 34
    Memory at f7400000 (64-bit, non-prefetchable) [size=4M]
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at f000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915

00:03.0 Audio device [0403]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller [8086:0c0c] (rev 06)
    Subsystem: CLEVO/KAPOK Computer Device [1558:5281]
    Flags: bus master, fast devsel, latency 0, IRQ 37
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:13d8] (rev a1) (prog-if 00 [VGA controller])
    Subsystem: CLEVO/KAPOK Computer Device [1558:5281]
    Flags: bus master, fast devsel, latency 0, IRQ 33
    Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at f0000000 (64-bit, prefetchable) [size=32M]
    I/O ports at e000 [size=128]
    Expansion ROM at f7000000 [disabled] [size=512K]
    Capabilities: <access denied>
    Kernel driver in use: nouveau
  • Remove all bumblebee and primus packages. Then add this ppa to your sources, update your sources & install nvidia-355 package which should also install nvidia-prime. Then reboot & you should be on nvidia drivers. With mobile nvidia gpu's you switch via the profiles option in nvidia-settings or from cli as following - To nvidia, sudo prime-select nvidia to intel, sudo prime-select intel Then log out/in. launchpad.net/~graphics-drivers/+archive/ubuntu/ppa – doug Nov 2 '15 at 2:46
  • Thank you for your reply as well, as i said on the other comment i've tried this option in the past as well, and still doesn't work. I get: quartilho@scud:~$ sudo prime-select nvidia [sudo] password for quartilho: Error: alternatives are not set up properly Error: nvidia mode can't be enabled – user467495 Nov 2 '15 at 10:13
2

Install the latest stable NVIDIA drivers supporting GTX970 from the Proprietary GPU drivers PPA.

Before you install new drivers uninstall every NVIDIA related software you have installed before.

Open a terminal and execute :

sudo apt-get purge nvidia* bumblebee  
sudo reboot

Install the latest current stable NVIDIA drivers from NVIDIA short-lived branch by executing :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-355 nvidia-prime
sudo reboot  

To switch between intel and nvidia graphics - open NVIDIA X Server Settings -> Prime Profiles.

Note : In case you have to adjust which card to use in BIOS select the switchable graphics mode.

  • Thank you for your post, I tried that in the past as well and what happens is this: postimg.org/image/fqfqhmk9v So i doens't really let me choose the graphics card. I've searched in BIOS as well and there is NO option to switch cards. – user467495 Nov 2 '15 at 9:54
  • @GuilhermeQuartilho : I suggest that you repeat your attempt by following my instructions once again ... wish you best luck for being successful ! :) – cl-netbox Nov 2 '15 at 10:25
  • I did it 3 times, didn't work and i tried several other things that i see on the forum, so i ended up doing a clean ubuntu installation from scratch and now everything is working as it should be, thank you very much for your time and help! – user467495 Nov 3 '15 at 23:49
  • I had problems with the nvidia-364 kernel (black screen on reboot). Using the nvidia-361 kernel drivers and running sudo nvidia-xconfig before the second reboot (to generate a new xorg.conf file) was successful. The problem with 364 may have to do with kernel mode setting stuff (just a guess, see here: wiki.archlinux.org/index.php/kernel_mode_setting). – hunse Apr 13 '16 at 16:55
  • @hunse : Interesting ... when you install the NVIDIA drivers this way -> askubuntu.com/questions/750303/… there should be no necessity to add any parameter afterwards and configure anything manually at all. :) – cl-netbox Apr 13 '16 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy