I am trying to get Unity 3d running on Ubuntu 11.10

I ran the test shared on this post How to enable Unity 3D on an Nvidia Quadro 1000M

and I got this result:

me@Dell-Ubuntu:~$ /usr/lib/nux/unity_support_test -p
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: unable to create the OpenGL context

I have a Dell XPS 15 L502x with Geforce 555M 1GB graphics card.

How can I enable Unity 3D with this setup? Thanks

  • It is also frustrating trying to answer questions when we are given insufficient information. Have you installed the proprietary Nvidia drivers? We have no way of knowing how much you already know. I could give the obvious answer to your question only for it to be a stupid answer because you already know it. – grahammechanical Oct 20 '11 at 10:52
  • I tried to give as much info as possible, of course if somebody asks me for the required info I will give it. I have the additional drivers dialog box open and I have installed nvidia_current. It says that it is is active but not in use. Do you require any other info to be able to help? Thanks. – urok93 Oct 20 '11 at 11:31
  • @drtanz - you've got optimus technology I think - have a look at this webpage (its not specific to edubuntu...) - you need to use either bumblebee or ironside - search for these terms on this website for similar questions and answers. Hope this helps. wiki.edubuntu.org/HardwareSupport/Machines/Laptops/Dell/XPS/15 – fossfreedom Oct 21 '11 at 16:15

Bumblebee and your graphics card were already largely discussed here. Have a look.

Basic recommendation is stay away from optimus, nvidia does not give driver support for linux on those yet!

The only methods known to do anything in your graphics is to disable the nvidia card with acpi calls, saves battery but that wont do any good on turning your unity3d on, you will be running with your default Intel card, which is also a very bad thing.

  • Thanks I installed Ironhide, how do I make sure it's working? Unity 3d is ok now, but I want to make sure Ironhide is active, how can I do that? – urok93 Oct 22 '11 at 16:24
  • if glxinfo | grep direct is yes you will be using acceleration and your glxgears looks ok I think that will be a good sign. – Bruno Pereira Oct 22 '11 at 16:31
  • yep both are working – urok93 Oct 22 '11 at 17:12
  • gl and keep looking around askubuntu, drivers are not out yet but lets pray that nvidia starts supporting these chips soon :) – Bruno Pereira Oct 22 '11 at 17:13

I have a dell xps and i had this problem: The "optimus" technology that is used to switch between the nvidia graphics card and the integrated graphics is not supported by the nvidia drivers given. So you cannot run 3d-graphics. Because it will always use the integrated graphics instead of the nvidia graphics. This is a frustrating problem because the card keeps consuming power while not doing anything.

I haven't found a solution yet. I don't know if this is the same problem you are having but it might be.

  • Sounds like the same problem. Does your laptop however display nvidia as its graphics card in sysinfo? Would it still be using the integrated graphics if it showed that its using nvidia in sysinfo? – urok93 Oct 21 '11 at 16:07

Graphics cards seem to have become a large issue with the 11.10 release. nVidia has been especially plagued with its fair share. The best you can do at this point is to upgrade the driver, restart, and attempt to test again.

Since nVidia is not an open source driver it's completely reliant on the company itself to fix this issue, which could take some time to do.

  • I updated and restarted, still same problem So there's no fix then? This is quite a disappointment :S – urok93 Oct 21 '11 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.