22

I have set the default terminal emulator to terminator using update-alternatives and I can open terminator now with ctrl-alt-t, but when I use the right click menu on the desktop or in a folder it will open gnome-terminal.

Is there another setting to change to fix this?

I've edited compiz to try the 3d cube effect and from then had to reset compiz to default settings to revert which reset my terminal default. To get ctrl-alt-t working after this I also had to do gsettings set org.gnome.desktop.default-applications.terminal exec 'terminator'. I found this suggestion in How can I set default terminal used in Unity?, but this did not make it so the right click option open terminator.

I am using Ubuntu 15.10

1
  • The problem is that it's not supposed to be changed: the entry is "Open in Terminal" (mind the uppercase "T"). It's supposed to open Terminal, which is the Unity .desktop front-end to gnome-terminal, not a generic terminal. Nonetheless it would be indeed nice to have options.
    – kos
    Nov 1 '15 at 17:15
16

The settings in gsettings set org.gnome.desktop.default-applications.terminal exec doesn't affect the behavior of the context menu entry. The used terminal is gnome-terminal and that's hard coded in libterminal-nautilus.so in the package gnome-terminal. And this library is used by Nautilus.

Perhaps this will be changed in future versions, but currently it is a fact.

3
8

A solution that might work is to add a custom right-click option to the Ubuntu context menu entry instead of changing the pre-existing one.

For that purpose you can use the Nautilus-Actions Configuration Tool that you can get from the repository using sudo apt-get install nautilus-actions.

A quite well detailed tutorial can be found here.

1
  • 2
    I liked this answer but it did not say what to put into that nautilus action, I found it out though: terminator into Path and --working-directory=%d/%b into Parameters then as it says later in the tutorial: "click the Preferences button in the Nautilus-Actions Configuration Tool window and uncheck the “Create a root ‘Nautilus-Actions’ menu” option"
    – Cold_Class
    May 15 '18 at 22:18
5

Add this to your ~/.bashrc file

if ps -o cmd= -p $(ps -o ppid= -p $$) | grep -q gnome; then
  nohup terminator &> /dev/null &
  sleep 0.1s
  exit
fi
3
  • 1
    How would this solve OP's problem? Also, wouldn't this cause other possible weirdnesses in theory?
    – Kaz Wolfe
    Jul 7 '17 at 16:41
  • 3
    This will check if the current terminal is gnome-terminal and then open a terminator session from gnome-terminal and then close the gnome-terminal. nothing here causes weirdnesses.
    – Ohad Rubin
    Jul 7 '17 at 16:48
  • 1
    Wow. That's what I call lateral thinking. If mildly insane in principle, this works flawlessly in practice (on 17.04). Dec 24 '17 at 12:00
3

If you don't want to use gnome-terminal on a regular basis, and you don't mind the possibility of having your hack disturbed by package upgrades, and other occasional problems, you could try removing /usr/bin/gnome-terminal (or renaming it) and replacing it with a symlink to terminator.

A slightly less intrusive approach, that would work if the context menu respects PATH, would be to leave /usr/bin/gnome-terminal alone, but add a symlink from /usr/local/bin/gnome-terminal to /usr/bin/terminator, so that anything running gnome-terminal without a fully-qualified path actually gets terminator.

Not the answer you're looking for? Browse other questions tagged or ask your own question.