0

I have a few music files in aac format which I want to play through VLC. But VLC ain't playing any of them. It's not showing any error or any other message, it simply stops as soon as I play them.

I have installed Ubuntu restricted extras package and I can play those files in Rhythmbox and Videos, so I know it's neither files nor codecs to do anything with it.

Similarly, I have a webm video which is not playing with VLC. It shows error stating VP90 format not supported. Though same file runs absolutely fine through Videos application. However, I may play various other webm videos in VLC.

I always read that VLC plays all formats, even if one does not have suitable codecs installed. So, what's going on and how can I fix it?

1

You should specify which version of Ubuntu you are using (Desktop [LXDE, XFCE, KDE, Mate, Unity], which processor type [32-bit, ia64, 64-bit and so on] and which edition you are using [12.04, 14.04, 16.04 or other]) to enable the answers you are presented to be more accurately directed at your needs.

If you have ubuntu restricted extras installed you should also have ffmpeg [and here is where the edition of Ubuntu is important because gstreamer0.10-ffmpeg does not exist for 16.04] installed as well as libavcodec54 libav-tools, ffmpeg, gstreamer0.10-ffmpeg, libavcodec-extra-53, libavcodec-extra-54 and/or others to ensure you have full coverage for (nearly) all audio and video file types you should follow and install the list of codecs and apps presented by Arch Linux (I am only linking to Arch Linux because I have not been able to discover a Ubuntu page which covers as much and Arch Linux covers things exceptionally well on the following page) - https://wiki.archlinux.org/index.php/codecs But, if you are only concerned with AAC and have already installed Ubuntu-Restricted-Extras (as you stated you had) then I strongly suggest installing Clementine which does play AAC so long as the codec is installed (and for you it is because you made clear that you have already installed Ubuntu restricted extras). So, sudo apt-get install clementine and you will be able to play AAC files using that application.

Apart from installing clementine if you must use VLC then you need to install a few more packages. sudo apt-get install libavcodec-extra libavcodec-ffmpeg-extra56 libavcodec-ffmpeg56 libavutil-ffmpeg54 Once installed, open VLC and in the settings make the following changes: Open VLC. Click "Tools" then click "Preferences" In preferences select "All" in Show Settings at the bottom of the window. Find "Input / Codecs" then "Video Codecs". Now click "FFmpeg" and scroll down (on the right) until you see "Strict Standard Compliance" and change it to -2, then "Specify AAC Audio Profile" to use hev2 (just type it in after removing what was there). Save it and your VLC will play AAC files.

As for webm files I do not have as much nor am able to find one so I cannot provide a useful answer (except to say that VideoLaAN, the company which makes VLC states that webm files are covered after VLC version 1.1.0, but that was released years ago). I will continue to look for a webm file and try to provide you a manner to enable as much in your VLC.

|improve this answer|||||
  • A.K. Pandey, has this solved the issue & answered your question? Having tested it with multiple machines & architectures where it succeeded: (including my 3 - Raspberry Pi 2 B; AMD64 GX processor Gizmo 2 (x2); Intel Core 2 Quad X9100 64-bit x86 in an HP HDX18t Laptop), 2010 Mac Mini (unsure of the processor in this system), Intel Core i5 -2500 in a Dell PC & lastly an Intel core i7-4770K in a PC built by me for a friend, all running Ubuntu Mate 64-bit except Mac & Pi (which are 32-bit). If so, please mark my answer as having solved your question. As it worked on all other, I expect it has. – monkeyman_stones Jul 24 '16 at 20:14
0

I had a similar problem where I installed VLC using the Ubuntu Software app. I had previously used it on Ubuntu 18 and played .webm videos without any problem but this happened when I installed Ubuntu 19.04 Disco Dingo just today. I just uninstalled it through the Ubuntu Software and reinstalled it through the command line, fortunately, it solved the problem. Now I can play .webm video files without any problem:

$ sudo apt-get install vlc
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.