4

Openssh seems to locate my id_rsa key but then after:

debug2: we sent a publickey packet, wait for reply

It start over again with:

debug1: Authentications that can continue: publickey,password

And eventually asks for a password instead of using my publickey.

From the log I can't really see what is going wrong...

This is the output concerning the authentication:

debug2: key: /opt/redmine/.ssh/id_rsa (0x7fe9e43e2900),
debug2: key: /opt/redmine/.ssh/id_dsa ((nil)),
debug2: key: /opt/redmine/.ssh/id_ecdsa ((nil)),
debug2: key: /opt/redmine/.ssh/id_ed25519 ((nil)),
debug1: Authentications that can continue: publickey,password
debug3: start over, passed a different list publickey,password
debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /opt/redmine/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /opt/redmine/.ssh/id_dsa
debug3: no such identity: /opt/redmine/.ssh/id_dsa: No such file or directory
debug1: Trying private key: /opt/redmine/.ssh/id_ecdsa
debug3: no such identity: /opt/redmine/.ssh/id_ecdsa: No such file or directory
debug1: Trying private key: /opt/redmine/.ssh/id_ed25519
debug3: no such identity: /opt/redmine/.ssh/id_ed25519: No such file or directory
debug2: we did not send a packet, disable method
debug3: authmethod_lookup password
debug3: remaining preferred: ,password
debug3: authmethod_is_enabled password
debug1: Next authentication method: password

Anyone a pointer where to look where this is going wrong?

  • Whats the output of grep 'IdentityFile' /etc/ssh/ssh_config ? – heemayl Nov 1 '15 at 8:02
  • grep 'IdentityFile' /etc/ssh/ssh_config # IdentityFile ~/.ssh/identity # IdentityFile ~/.ssh/id_rsa # IdentityFile ~/.ssh/id_dsa – Gerard van den Bosch Nov 1 '15 at 8:06
  • Remove the # from the front of line IdentityFile ~/.ssh/id_rsa and then check.. – heemayl Nov 1 '15 at 8:20
  • Output stays the same after the change, it still asks for password – Gerard van den Bosch Nov 1 '15 at 8:23
  • No it should not..whats the output of file /opt/redmine/.ssh/id_rsa? – heemayl Nov 1 '15 at 8:28
2

The problem is in the ssh server. The authorized key file is set as /opt/gitolite/.ssh/authorized_keys but the file contains the path to the public key of the client rather that the key itself.

To solve this issue you need to copy the public key as it is to the /opt/gitolite/.ssh/authorized_keys file removing all other existing irrelevant contents of the file. Note that this file should be owned by the appropriate user and the permission bits should be 600.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.