1

I've upgraded to ubuntu 15.10 and I lost the mic in my skype. The mic was working correctly before the upgrade.

The mic is working when testing it in the Setting->Sound->input area. It is marked as Microphone, QuickCam Communicate MP/s5500

When looking into the Skype mic settings, there is only one option in the drop down menu: Options->Sound Devices->Michrophone = PulseAudio server (local)

There is no Camera option as there was before.

Any idea? Thanks

0

Delete the pulseaudio config and profile files so that pulseaudio is forced to generate new ones:

rm -r ~/.pulse/

restart pulseaudio or your computer afterwards

1
  • Thanks, the pulseaudio is recognizing the camera's mic. I can see the input camera volume running while checking the pulseaudio volume settings. Skype does not have the option to change to the camera mic – Drorasta Nov 1 '15 at 9:30
0

Answering my own question.

The problem was due to the default profile of the sound card. After the upgrade I initially had sound but no mic on Skype as described in this question. But later I lost all sound on the computer and opened another question on it.

My other question on askubuntu regarding the sound

I found that the card default is set to Digital and not Analog each time I switch to another sound card (my TV is connected to the computer). So I need to set it manually each time I come back to the Computer's sound card using the

Pulseaudio Volume Control

The same worked for the Skype mic. You can access it directly from Skype settings if you have the Pulseaudio Volume Control installed.

enter image description here

0

I just fixed this last night with my MX Revolution mouse and keyboard -- may work for you too. Here's what I found on a french site:

Edit /lib/udev/rules.d/97-hid2hci.rules

Change this line:

KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[3bc]", \
  RUN+="hid2hci --method=logitech-hid --devpath=%p"

to be this (Change hiddev* to hidraw*):

    KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[3bc]", \
      RUN+="hid2hci --method=logitech-hid --devpath=%p"
2
  • I do not see any difference between the two lines of code... – vmalep Jan 21 '16 at 19:57
  • Oops -- fixed it now :) – David Frascone Jan 22 '16 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.