1

I'm trying to mount an IOmega NAS drive through fstab, but it doesn't mount on boot. All devices are on the same 192.168.1.x network.

After running dmesg, what I get is:

[    1.916474] CIFS VFS: Error connecting to socket. Aborting operation.
[    1.916844] CIFS VFS: cifs_mount failed w/return code = -101

My fstab reads:

//192.168.1.29/Musica         /mnt/hmnhd-ticroj/music     cifs    _netdev,gid=xxx,uid=xxx,credentials=/home/xxx/credentials.txt,rw    0   0

so that, after booting, the manual mounting:

$ sudo mount -a

works fine.

Actually, this fstab file worked also fine with Ubuntu 14.04, and stopped working when I upgraded to 15.10. I have the feeling that fstab doesn't wait for the network, even though the option _netdev has been included, but this is just my feeling.

Any ideas?

  • I do a similar mount but I don't use the _netdev, gid, or uid options. My line in fstab looks like this. the important part might be nobootwait. //192.168.1.2/Digital\040Photos /media/ST8-Photos cifs credentials=[credential file],iocharset=utf8,sec=ntlm,file_mode=0777,dir_mode=0777,nobootwait 0 0 – Organic Marble Oct 30 '15 at 22:36
  • I have tried using your options, but, unfortunately, it didn't solve the problem. After a verbose manual mounting, I also get a strange message: Credential formatted incorrectly: (null). All drives are properly mounted, though. – Oscar Alejos Nov 2 '15 at 16:24
2

comment=systemd.automount fstab parameter helped me.

Example fstab:

//host/share /media/user/share cifs _netdev,comment=systemd.automount,credentials=/path/to/.smbcredentials,sec=ntlm,file_mode=0777,dir_mode=0777   0 0

Reference

  • 2
    If you could make that answer more detailed it would be nice. A link to a website may change and your answer would be lost as the internet is not a static place. – KGIII Nov 3 '15 at 8:00
  • The option you suggested seems to have done the trick. Good job! – Oscar Alejos Nov 4 '15 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.