3

I have a Asus K550JK (Ubuntu shows X550JK) with a intel hd 4600 and nvidia 850m. When trying to install Ubuntu 15.04, the same error nouveau unk06 used to flood, I would just set nomodeset to the kernel parameters and install 15.04 and then Just install bumblebee. After that nomodset would not be needed and my laptop worked fine on ubuntu.

But when 15.10 came out, I tried to setup and same nouveau error unk06 started flooding. From experience I just added nomodeset to boot parameters and installed. Then I tried installing bumblebee and after reboot the screen went black after the ubuntu bootloader/loading little circles animation.

So I though bumblebee isnt compatible with 15.10 so I clean installed again using nomodeset. Then went in and installed a propeitory driver from ubuntus Additional drivers section. Upon reboot, same problem, black screen. I tried different drivers and the results were same. Black screen. Some older drivers give a purple screen, nvidia optimus gives a login loop.

I'm not sure what logs I can/need to post since I cant access the laptop as it goes black screen. But I'm sure with instructions I can do it.(It starts fine on recovery mode on a low resolution. ) As I use ubuntu just for programming and web browsing and other simple non graphical tasks, I would be happy if I could just use the intel gpu and ubuntu would turn off the nvidia alltogather(if that was a solution that is). But the bios does not have any option for disabling the nvidia gpu.

Is there any other way to solve this except for going back to 15.04? I dont even want to use the nvidia gpu on Ubuntu, the intel internal gpu is all I need.

4

To solve your problem install the very latest current stable NVIDIA drivers 352 !

But first uninstall every NVIDIA related software you have had installed before.

Remove the bumblebee packages as well - it will be replaced with nvidia-prime.

Open a terminal and execute:

sudo apt-get purge nvidia* bumblebee  
sudo reboot

Then install the new NVIDIA drivers:

sudo apt-get update
sudo apt-get install nvidia-352 nvidia-prime
sudo reboot  

Open NVIDIA X Server Settings -> Prime Profiles to switch to the intel graphics card.

  • Thanks, this is what worked for me. But I had to use the nvidia-352 open source driver , 355 did not work. And another thing was that I had to set it to use the intel card before rebooting. So basically I installed the 352 driver instead of 355 in this post. then before doing sudo reboot, I just did sudo prime-select intel and THEN rebooted. Now my laptops is running fine. Although I am facing another issue with power not auto switching to AC when battery is fully charged, but Its not related to this one. Just gave a heads up to anyone who has this same laptop and found this thread. – Sohan Chowdhury Nov 2 '15 at 17:52
  • @SohanChowdhury nvidia-352 is not opensource it is proprietary – mchid Jan 31 '16 at 0:03
  • @mchid I'm sorry but it says open source on the !Additional drivers section , so I'm not sure if you are correct or not. – Sohan Chowdhury Feb 5 '16 at 11:09
  • 1
    @SohanChowdhury : This is only shown so because you have the Proprietary GPU Drivers PPA enabled. When you disable graphics-drivers/ppa in the Other Software tab in Software & Updates and reload it afterwards, then you should see (proprietary) in the Additional Drivers tab - it is just shown misleading. – cl-netbox Feb 5 '16 at 11:45
  • OK sorry about that. I cant edit the previous comment or I would have fixed it. – Sohan Chowdhury Feb 5 '16 at 15:04
2

Maybe you didnt install bumblebee correctly! I suggest you follow the below instructions: Make sure you've removed any nvidia-driver:

sudo apt-get remove --purge nvidia*
sudo apt-get install nvidia-common ubuntu-desktop

Basically you do this:

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get update

install bumblebee and the nvidia driver

sudo apt-get install bumblebee bumblebee-nvidia nvidia-355 nvidia-settings

then you need to gksudo gedit /etc/modules and add

i915
bbswitch

then you need to gksudo gedit /etc/modprobe.d/bumblebee.conf and make sure the line

blacklist nvidia-355

is there, if not add it.

finally you need to gksudo gedit /etc/bumblebee/bumblebee.conf

  • line 22: >Driver=nvidia
  • line 55: >KernelDriver=nvidia-355
  • line 58: >LibraryPath=/usr/lib/nvidia-355:/usr/lib32/nvidia-355
  • line 61: >XorgModulePath=/usr/lib/nvidia-355/xorg,/usr/lib/xorg/modules

If you are using a more recent kernel on your system (e. g. v4.4 from Xenial LTS) you also need to edit /etc/default/grub and make sure it adds the boot parameter nogpumanager:

GRUB_CMDLINE_LINUX="nogpumanager"

then

update-grub

reboot.

This answer comes from: http://rajat-osgyan.blogspot.gr/2015/05/how-to-install-latest-nvidia-driver-in.html

see there for more explanation. It is approved by many (and me)to work, though the difference is that I don't use ppa:xorg-edgers (since it is unstable) and use ppa:bumblebee/stable, I recommend you do that instead.

intel core i5-3210m, GT 650M

  • so that it doesn't conflict with the intel drivers while loading the display! It should load whenever you tell it to with primusrun/optirun (whenever you want to run a graphics-heavy application) to save power – philsegeler Jan 31 '16 at 13:16
  • I see the OP doesn't even want to use nvidia. – mchid Feb 1 '16 at 1:13
0

Remove everything to do with the Nvidia proprietary drivers.

sudo apt-get remove --purge nvidia-*

Start from scratch.

sudo apt-get remove --purge xserver-xorg-video-nouveau xserver-xorg-video-nv

Reinstall all the things

sudo apt-get install nvidia-common sudo apt-get install xserver-xorg-video-nouveau sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

Reconfigure the X server.

sudo dpkg-reconfigure xserver-xorg

Source: Ubuntu Wiki

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.