I had a problem with Lightdm, each time I put my pc to sleep and wake up, it showed up no user, but asked for password and none worked.

And I don't know if it's dumb, but I also ran locate lightdm | xargs sudo rm -r -f to remove all lightdm files

I uninstalled and reinstalled lightdm with lightdm-gtk-greeter and settings, but now when I boot up, it says just 2 things:

[ OK ] Started Light Display Manager.
[ OK ] Started ACPI event daemon.
       Starting ACPI event daemon...

and it flashes screen like 5 times and it stops. Nothing happens. I have to alt+f1 and manually login + startx to see anything.

How to fix this stuff?

  • Can you check the LightDM logs in /var/log/lightdm?
    – Prolix
    Oct 30, 2015 at 11:00
  • x-0-greeter.log just says: Error writing X authority: Failed to open X authority /var/lib/lightdm/.Xauthority: No such file or directory
    – VixinG
    Oct 30, 2015 at 11:06
  • Might it be a owner issue? Try typing chown lightdm.lightdm /var/lib/lightdm/
    – Prolix
    Oct 30, 2015 at 12:18
  • 1
    @VininG The bug above or similar problems can be corrected without reinstalling using: mkdir -p /var/lib/lightdm; chown -R lightdm:lightdm /var/lib/lightdm ; chmod 0750 /var/lib/lightdm with root permission if needed.
    – Prolix
    Oct 30, 2015 at 17:30

1 Answer 1


Tried everything, even copied the configuration from another computer.

Finally fixed it with writing this into console:

sudo -u my_username /usr/sbin/lightdm --test-mode

it opened the lightdm session in new window and I simply chose to reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.