10

When I click Menu then Shutdown (Quit) i get the following dialog:

______________________________
| Session                   x |
______________________________
|                             |
| Shutdown this system now?   |
| __________                  |
| |Cancel  x|                 |
-------------------------------

(Seems like I can't press print screen when the shutdown dialog is open so I can't provide a screenshot for this issue.)

Why have I only got a cancel button and how do I fix this as there used to be shutdown, reboot, logout?

15

Found this somewhere else and it fixed the problem for me.

Updating to Cinnamon 2.6 (using the PPA ppa:moorkai/cinnamon), and executing the commands below, has solved the issue for me (after a restart).

gsettings set org.cinnamon.desktop.session settings-daemon-uses-logind true
gsettings set org.cinnamon.desktop.session session-manager-uses-logind true
gsettings set org.cinnamon.desktop.session screensaver-uses-logind false
  • Had this same issue, while running cinnamon on Ubuntu 14.04. This did the trick (reboot required, though) – Gregory Butron Jan 27 '16 at 14:27
  • I did it with dconf-editor but used the same keys. Logging out and in again was required, reboot would do the trick as well. – Amir Eldor Feb 15 '16 at 10:18
2
sudo apt-get install consolekit 

and reboot.

Worked for me.

1

Found this and worked for me: https://bbs.archlinux.org/viewtopic.php?pid=1533771#p1533771

I was able to fix that using dconf-editor under org.cinnamon.desktop.session set session-manager-uses-logind to true then logout and back in again and shutdown button should be working.

0

Eventually figured out that if you install dconf-editor then open it and browse to apps->indicator-session, there are some check boxes there, I ticked them all to get the buttons back. Weird because they are all labelled as suppress, ticking them enabled the buttons?

Anyways... It works.

enter image description here

0

I,ve fixed the bug on Ubuntu 14.04. I am running Cinnamon 2.8 and using dconf under org.cinnamon.desktop.session set session-manager-uses-logind to true should resolve the problem.

Write this on yor terminal:

gsettings set org.cinnamon.desktop.session session-manager-uses-logind true

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.