0

I just ran apt-get dist-upgrade from 14.04.2 and it upgraded ubuntu to 14.04.3. But when i rebooted my laptop my gui wont boot. I tried purging the nvidia drivers (sudo apt-get purge nvidia*) and reinstall (sudo apt-get install nvidia-current nvidia-settings) but with no luck.

Any ideas why my drivers would start to fail after dist-upgrade?

EDIT: I noticed that if I let my laptop go to sleep and then waking it up the GUI boots correctly with nvidia-346 drivers so it seems the drivers work but something isnt booting correctly. Any ideas what?

I have a gefore gtx 860M (also intel 4400).

  • 1
    What do you mean by upgrading from 12.04.2 to 12.04.3? How you did that? – Pilot6 Oct 29 '15 at 22:13
  • I ran sudo apt-get update, sudo apt-get upgrade and sudo apt-get dist-upgrade which I think changed my ubuntu version from 14.04.2 to 14.04.3. – Bubbad Oct 29 '15 at 22:18
0

You install wrong Nvidia drivers.

nvidia-current installs legacy drivers that do not support your adapter.

Run this:

sudo apt-get purge nvidia*
sudo apt-get install nvidia-346 nvidia-prime

and reboot.

  • Unfortunately still gives me black screen. Any other idea? – Bubbad Oct 29 '15 at 22:00
  • Did the drivers install without errors? – Pilot6 Oct 29 '15 at 22:02
  • Yes no errors in the install – Bubbad Oct 29 '15 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.