4

Every time I try to install or remove or whatever action via apt-get i get:

libreoffice-core : Depends libreoffice-common (>1:5.0.2)

But it won't be installed and a suggestion:

Try <<apt-get -f install>>

But when I run the last command, it returns the same error. I removed libreoffice because I don't use it, I've even tried to reinstall it but I can't. How can I fix this? I am using Ubuntu 14.04

EDIT:

This is the output for: lsb_release -a; uname -a; apt-cache policy libreoffice-core libreoffice-common

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.3 LTS
Release:    14.04
Codename:   trusty
Linux teclalabs 3.13.0-66-generic #108-Ubuntu SMP Wed Oct 7 15:20:27 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
libreoffice-core:
  Instalados: 1:5.0.2-0ubuntu1~trusty1
  Candidato:  1:5.0.2-0ubuntu1~trusty1
  Tabla de versión:
 *** 1:5.0.2-0ubuntu1~trusty1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     1:4.2.8-0ubuntu2 0
        500 http://pe.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
     1:4.2.3~rc3-0ubuntu2 0
        500 http://pe.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
libreoffice-common:
  Instalados: (ninguno)
  Candidato:  1:5.0.2-0ubuntu1~trusty1
  Tabla de versión:
     1:5.0.2-0ubuntu1~trusty1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ trusty/main amd64 Packages
     1:4.2.8-0ubuntu2 0
        500 http://pe.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
     1:4.2.3~rc3-0ubuntu2 0
        500 http://pe.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

EDIT:

This is the full output for LANG=C sudo apt-get install -f

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libreoffice-common
Suggested packages:
  libreoffice-style-breeze libreoffice-style-crystal
  libreoffice-style-hicontrast libreoffice-style-human
  libreoffice-style-oxygen libreoffice-style-sifr libreoffice-style-tango
The following NEW packages will be installed:
  libreoffice-common
0 upgraded, 1 newly installed, 0 to remove and 51 not upgraded.
11 not fully installed or removed.
Need to get 0 B/22.5 MB of archives.
After this operation, 83.7 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 341789 files and directories currently installed.)
Preparing to unpack .../libreoffice-common_1%3a5.0.2-0ubuntu1~trusty1_all.deb ...
Unpacking libreoffice-common (1:5.0.2-0ubuntu1~trusty1) ...
dpkg: error processing archive /var/cache/apt/archives/libreoffice-common_1%3a5.0.2-0ubuntu1~trusty1_all.deb (--unpack):
 trying to overwrite '/usr/bin/soffice', which is also in package openoffice-debian-menus 4.1.1-9775
rmdir: failed to remove '/var/lib/libreoffice/share/prereg/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice/share/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice/program/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
Processing triggers for gnome-icon-theme (3.10.0-0ubuntu2) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Errors were encountered while processing:
 /var/cache/apt/archives/libreoffice-common_1%3a5.0.2-0ubuntu1~trusty1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

EDIT:

Output after run sudo apt-get remove openoffice-debian-menus

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libreoffice-core : Depends: libreoffice-common (> 1:5.0.2) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

EDIT:

Full output for sudo apt-get install libreoffice-common

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  libreoffice-style-breeze libreoffice-style-crystal
  libreoffice-style-hicontrast libreoffice-style-human
  libreoffice-style-oxygen libreoffice-style-sifr libreoffice-style-tango
The following NEW packages will be installed:
  libreoffice-common
0 upgraded, 1 newly installed, 0 to remove and 51 not upgraded.
11 not fully installed or removed.
Need to get 0 B/22.5 MB of archives.
After this operation, 83.7 MB of additional disk space will be used.
(Reading database ... 341789 files and directories currently installed.)
Preparing to unpack .../libreoffice-common_1%3a5.0.2-0ubuntu1~trusty1_all.deb ...
Unpacking libreoffice-common (1:5.0.2-0ubuntu1~trusty1) ...
dpkg: error processing archive /var/cache/apt/archives/libreoffice-common_1%3a5.0.2-0ubuntu1~trusty1_all.deb (--unpack):
 trying to overwrite '/usr/bin/soffice', which is also in package openoffice-debian-menus 4.1.1-9775
rmdir: failed to remove '/var/lib/libreoffice/share/prereg/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice/share/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice/program/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
Processing triggers for gnome-icon-theme (3.10.0-0ubuntu2) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Errors were encountered while processing:
 /var/cache/apt/archives/libreoffice-common_1%3a5.0.2-0ubuntu1~trusty1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
13
  • When you execute apt-get -f install what is the error? You could try to do apt-get install libreoffice-common – Charles Green Oct 29 '15 at 18:26
  • @CharlesGreen I've tried that, everithing look ok after run apt-get install libreoffice-common but at the end i get dpkg: error processing file /var/cache/apt/archives/libreoffice-common_1%3a5.0.2-0ubuntu1~trusty1_all.deb (--unpack): and E: Sub-process /usr/bin/dpkg returned an error code (1) – Gocht Oct 29 '15 at 18:29
  • You should try sudo apt-get clean followed by sudo apt-get update && sudo apt-get upgrade – Charles Green Oct 29 '15 at 18:35
  • When I try apt-get upgrade I get the same error: libreoffice-core : Depend: libreoffice-common (> 1:5.0.2) but it is not installed PD: I don't know if it is the exact message in english I get my OS installed in spanish and I am translating. – Gocht Oct 29 '15 at 18:38
  • The first command sudo apt-get clean clears the downloaded .deb files - it may be that you have a corrupted file. – Charles Green Oct 29 '15 at 18:39
20

Some time ago you installed LibreOffice without success. Since this day the package manager has a problem and every time when you install something else the problem occurs.


The installation of LibreOffice collides with your OpenOffice installation.

trying to overwrite '/usr/bin/soffice', which is also in package openoffice-debian-menus 4.1.1-9775

Execute

sudo apt-get remove openoffice-debian-menus

If that does not work as in your case

sudo dpkg -r --force-all openoffice-debian-menus

Now repair your system

sudo apt-get install -f

5
  • This is like a circle, I edited the question with the result for the command in your answer, thanks. – Gocht Oct 29 '15 at 18:50
  • spectacular answer..solved my problem – Edziu Eames May 27 '16 at 22:35
  • Thank you buddy – Jijesh Cherrai Sep 26 '19 at 8:02
  • It solved the issue I was stuck in for very long – Kumar A. Apr 12 '20 at 15:56
  • This worked for me on 20.04: sudo dpkg -r --force-all openoffice-debian-menus – rjkunde May 26 '20 at 4:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.