1

My touchpad is detected as a mouse so no scrolling is possible.

  • laptop Asus G550JK, Xubuntu 14.04.2
  • dkms installed
  • xinput gives me "PS/2 Generic Mouse" where Elantech Touchpad should be
  • my touchpad seems to be ETD0105
  • already tried this

    sudo apt-get --purge autoremove xserver-xorg-input-synaptics && sudo apt-get install xserver-xorg-input-synaptics

  • and this

    sudo apt-get install --install-recommends xserver-xorg

  • and this

    sudo modprobe -r psmouse && sudo modprobe psmouse proto=imps

  • and tried to reconfigure driver according to this

    https://hardc0l2e.wordpress.com/2014/12/06/fix-for-elantech-touchpad-on-ubuntu-14-04/

  • dkms status gives me

    focaltech, 1.5~trusty1: added psmouse, elantech-x551c, 3.19.0-30-generic, x86_64: installed vboxhost, 4.3.30, 3.19.0-30-generic, x86_64: installed

Any help would be truly appreciated :-) Thank you.

  • Are you sure it is Elantech? What does dmesg | grep pnp show? – Pilot6 Oct 29 '15 at 18:02
  • @Pilot6 It shows this: [ 0.244800] pnp: PnP ACPI init [ 0.245070] pnp 00:02: Plug and Play ACPI device, IDs PNP0b00 (active) [ 0.245193] pnp 00:06: Plug and Play ACPI device, IDs ETD0105 SYN0a00 SYN0002 PNP0f03 PNP0f13 PNP0f12 (active) [ 0.245218] pnp 00:07: Plug and Play ACPI device, IDs ATK3001 PNP030b (active) [ 0.245708] pnp: PnP ACPI: found 10 devices I'm absolutely sure that there was Elantech Touchpad before I updated couple of things (graphical driver, boot settings, apt-get autoremove etc.). – Sebastian Oct 29 '15 at 18:07
  • It is an really an Elantech – Pilot6 Oct 29 '15 at 18:07
  • What is the kernel version uname -r? – Pilot6 Oct 29 '15 at 18:08
  • 3.19.0-30-generic – Sebastian Oct 29 '15 at 18:09
0

The problem is very clear. You installed a wrong Focaltech touchpad driver.

And it is installed from my PPA. Remove it this way:

sudo apt-get purge focaltech-dkms
sudo add-apt-repository ppa:hanipouspilot/focaltech-dkms

Then reboot.

The touchpad should work without any driver.

So also remove the Elantech one too by:

sudo dkms remove psmouse/elantech-x551c --all

If the touchpad does not work, then re-install the Elantech driver. I am not 100% sure that this specific model works on kernel 3.19.

| improve this answer | |
  • I removed the focaltech driver, rebooted (didn't work), then removed elantech driver and rebooted and still it's not working. Installed driver with > sudo dkms install psmouse/elantech-x551c And it's still not working. Damn it. – Sebastian Oct 29 '15 at 20:02
  • So install the elantech driver again. – Pilot6 Oct 29 '15 at 20:03
  • Should I use another install command, Pilot? – Sebastian Oct 29 '15 at 20:07
  • Well, you installed that psmouse-elantech-x551c.tar.gz. So try it again. But I am not quite sure that it is good for your model. – Pilot6 Oct 29 '15 at 20:09
  • No luck. I even tried what I found here (exactly my laptop): snakelab.cc/2015/01/09/running_ubuntu_on_asus_n550jk.html – Sebastian Oct 29 '15 at 20:23
0

I finally found the right solution that @jandurek pointed out here.

sudo rmmod psmouse
sudo insmod /lib/modules/`uname -r`/kernel/drivers/input/mouse/psmouse.ko

I added this to a startup script to enable two-finger scrolling right after ubuntu starts.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.