98

Suddenly copy/paste stopped working from/to Windows 8 host computer to/from ubuntu virtual machine. Ubuntu restart did not help. I tried command:

sudo apt-get install open-vm-tools

But got report I have newest version. Guest Isolation settings are enabled. What could be the scenario of fixing this problem?

3
  • Note that this is a known issue - there's an issued with shared files not working in a Linux VM, and it seems similar components of that don't work with VMware at this time.
    – Thomas Ward
    Commented Mar 19, 2016 at 21:54
  • Solution here: superuser.com/a/1323289/347416 Commented May 16, 2018 at 17:07
  • I noticed this problem has to do with me using a different window manager. VM shared clipboard works fine using gdm3, but when I switched to DWM shared desktop no longer worked
    – Max Coplan
    Commented Sep 20, 2019 at 18:44

9 Answers 9

84

I had the same problem and found that this can be fixed by executing the following commands:

  1. sudo apt-get autoremove open-vm-tools
  2. Install VMware Tools by following the usual method (Virtual Machine --> Reinstall VMWare Tools)
  3. Reboot the VM
  4. sudo apt-get install open-vm-tools-desktop
  5. Reboot the VM, after the reboot copy/paste and drag/drop will work!
19
  • 12
    I found I didn't need to install VMware Tools. Doing an apt-get of open-vm-tools, then open-vm-tools-desktop, and then restarting worked for me.
    – Billy
    Commented May 31, 2016 at 20:36
  • 3
    Did not work for me on Ubuntu 14.04 64bit.
    – Forivin
    Commented Jun 9, 2016 at 7:21
  • 4
    Didn't work for me either on 16.04 64 bit (server)
    – Mahn
    Commented Jul 10, 2016 at 17:50
  • 4
    Removing open-vm-tools and rebooting destroyed my kernel and I had to reinstall the OS from scratch.
    – dionyziz
    Commented Oct 14, 2016 at 21:20
  • 1
    Did nothing for me on Ubuntu 16.10 Commented May 17, 2017 at 9:51
71

I tried the approach suggested by solution101 above, but it didn't work for me. This is how I solved the problem:

  1. Open Terminal
  2. sudo apt install open-vm-tools-desktop
  3. restart the guest operating system

This seems to have fixed the copy-and-paste issue for me.

7
  • This worked for me in Ubuntu 17.04 running on a macOS Sierra host - thanks! Commented Sep 12, 2017 at 15:30
  • Worked on Windows 7 / VMware Player - Ubuntu 16.04. Thanks.
    – S..
    Commented Apr 23, 2018 at 12:11
  • 3
    Worked for Ubuntu 18.04. I had missed open-vm-tools-desktop.
    – johnthagen
    Commented Jun 6, 2018 at 15:22
  • 8
    you only need to do open-vm-tools-desktop because that installs open-vm-tools automagically
    – JREAM
    Commented Jul 29, 2018 at 19:45
  • @218, can u please update your answer per JREAM's comment ? thanks
    – killjoy
    Commented Sep 27, 2018 at 17:46
16

This is copied verbatim from a vmware community forum:

  1. Go into VM / Settings / Options / Guest Isolation
  2. UNCHECK bothcheckboxes (Enable drag and drop, Enable copy and paste) and click OK.
  3. Shut down the guest, and shut down VMware Workstation
  4. Reboot the host computer
  5. Run VMware Workstation but do not launch the guest yet.
  6. Go into VM / Settings / Options / Guest Isolation for the guest, and
  7. CHECK both checkboxes
  8. Power On the guest.
9
  • 2
    I don't have this Guest Isolation option
    – Alaa M.
    Commented Dec 18, 2016 at 8:44
  • @AlaaM. Perhaps they have removed the feature? I no longer run VMWare, but instead am using KVM/QEMU for virtual machines. Commented Dec 18, 2016 at 14:05
  • Maybe. But it's ok looks like i just had to sudo nautilus and then i could drag and drop
    – Alaa M.
    Commented Dec 18, 2016 at 14:07
  • 4
    Did nothing for me on Ubuntu 16.10 Commented May 17, 2017 at 9:52
  • I'm using ubuntu 17.04 32-bit. I just did step: 1,2,3,[no 4],5,6,7,8 ~ the paste works now
    – simomo
    Commented Jul 27, 2017 at 13:44
16

The best and working solution is restarting your VMWare application (Workstation, Fusion, etc.), not the VM itself. (provided, of course, that you have installed the VMWare tools already.)

3
  • 1
    This simple answer is what worked for me. Thanks! Commented Jun 27, 2017 at 17:34
  • 1
    I knew it had to be something simple! didnt even need to reboot my host.
    – n00b
    Commented Dec 12, 2017 at 1:40
  • In my case I also needed to restart the VMWare Workstation Server service (vmware-hostd.exe process). Just restarting VMWare application was not enough.
    – Alex Che
    Commented Aug 31, 2018 at 10:17
6

In my case, somehow the guest start-up job running the VMware User Agent was removed from my xfce session autostart. You need to run /usr/bin/vmware-user-suid-wrapper at login

3
  • Same with KDE 5.25. It worked fine in KDE 5.24, but now this needs to be manually run at startup it seems. Unfortunately just running it via KDE's autostart doesn't seem to fix the issue.
    – Slbox
    Commented Sep 28, 2022 at 20:08
  • running /usr/bin/vmware-user-suid-wrapper worked for me after trying @Charles Green (worked for me before but not this time)
    – KING SABRI
    Commented Apr 10, 2023 at 23:16
  • Nope. Ran it, confirmed running, still no working copy & paste.
    – John Smith
    Commented Nov 10, 2023 at 9:47
4

You can't uncheck the checkboxes while the VM is running; they are disabled. If you do this when the VM is not running, there is no effect (VMWare Workstation 12 Pro).

0
3

I can see how old this post is, but I noticed something relevant; it wasn't even Ubuntu. Apparently "Shared folders" must be enabled prior to installing open-vm-tools - also had open-vm-tools-desktop already installed and nothing worked. Reinstalling both packages does the job, seemingly when shared folder were enabled; this works instantly. With apt-get:

sudo apt-get install open-vm-tools open-vm-tools-desktop --reinstall

Or with dnf:

sudo dnf reinstall open-vm-tools open-vm-tools-desktop

I'd assume that when enabling "shared folder" before the OS install, it should work out of the box.

3
  • slight correction to command: "sudo apt-get install open-vm-tools open-vm-tools-desktop --reinstall".
    – Todd
    Commented Feb 23, 2022 at 18:02
  • 1
    @Todd Have corrected that; left the dnf syntax, because it may be useful. Commented Feb 23, 2022 at 21:49
  • Fans of my almost 200 different comments pointing out "solutions" that don't work at all, and exactly 0 that do, will be not at all surprised to know that, surprise, this does not work at all. Still no copy & paste.
    – John Smith
    Commented Nov 10, 2023 at 9:50
1

If you are using the VMware Remote Console or Vsphere Client, then it wont work by just installing VMware tools.

You need to follow the steps described here.

To resolve this issue, first install or upgrade the VMware tools for the Windows/Linux virtual machine(VM). For more information see Installing and upgrading VMware Tools in vSphere.

enter image description here

  • Click on Add Configuration Params three times to give three rows

  • Fill in the Name and Value fields as mentioned below:


Name:                                 Value:
isolation.tools.copy.disable          FALSE
isolation.tools.paste.disable         FALSE
isolation.tools.setGUIOptions.enable  TRUE
2
  • I don't see "Add Configuration Params" in that window.
    – Henno
    Commented Nov 3, 2022 at 14:19
  • Maybe you need to shutdown the VM first.
    – Black
    Commented Nov 3, 2022 at 14:37
0

In my case in addition to bidirectional button activation, I had to do following steps: On the terminal of guest virtual machine run:

sudo apt update && sudo apt install -y make gcc perl

Now on virtual machine's main menu go: "Devices" -> "Insert Guest Additions CD image" -> wait popup to appear -> follow up installation steps -> once it's done go reboot In my case it has resolved copy&paste issue

2
  • 1
    Perfect. This is the only answer that worked. Thanks !!!
    – Zentag
    Commented Jul 22, 2021 at 22:07
  • No, no, and no. I already have the latest versions of those packages installed. This does... drum roll please... not work! Just like, apparently, literally 100% of the linux solutions on Stack Overflow, of which I have literally tried almost 200 at this point (I counted, it was 183 a few hours ago) with not so much as a single one of them ever solving the problem they claimed to solve.
    – John Smith
    Commented Nov 10, 2023 at 9:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .