0

I just installed Ubuntu 15.10 on my dell latitude 3340 and now i cannot enable wifi since it is greyed out. Is there anyone who can help me with this? Any help is much appreciated!

PS here is a link with additional info about my wifi: http://paste.ubuntu.com/12999579/

dmesg | grep rename results in:

[    1.308743] e1000e 0000:00:19.0 eno1: renamed from eth0
[    2.600819] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
13
  • Please execute the statement dmesg | grep rename and append the results of this to your question. I also had an issue with WiFi, and was able to resolve it, but it was not easy. Oct 29, 2015 at 15:27
  • 1
    Possible duplicate of Wifi losing connection, weak signal, Intel 7260 adapter
    – Pilot6
    Oct 29, 2015 at 15:27
  • @Pilot6 I'm not sure this is a duplicate: for me, the same issue was the renaming of the wifi link that occurs during the boot processes. Oct 29, 2015 at 15:29
  • The problems with this adapter can be solved the way it is answered to the other question.
    – Pilot6
    Oct 29, 2015 at 15:30
  • The result of dmesg | grep rename is: [ 1.308743] e1000e 0000:00:19.0 eno1: renamed from eth0 [ 2.600819] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
    – ARTLAUROO
    Oct 29, 2015 at 15:32

1 Answer 1

2

In my Dell 5521, the problem is related to renaming of the wireless adapter at boot time.

To prevent adapter renaming, I use a kernel parameter net.ifnames=0

Open a terminal window (Ctrl+Alt+t), and enter:

sudo nano /etc/default/grub

Change the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash net.ifnames=0"

Press Ctrl+o and Ctrl+x to save and exit, then enter

sudo update-grub sudo reboot

9
  • I tried the first part of your answer, but i get stuck at the point where i need to execute the command cat /sys/class/network/<wlan new name>/address because i get the error cat: /sys/class/network/wlp3s0/address: No such file or directory I checked and there is indeed no network folder with that address, any idea what the cause of this may be?
    – ARTLAUROO
    Oct 29, 2015 at 16:26
  • Dang! it should have been /sys/class/net/wlp3s0/address : I knew I should have triple checked the syntax! Oct 29, 2015 at 16:30
  • I did all the steps but there is still no change, the "enable wifi" setting is still greyed out.. Thanks for your help though! If you still have any ideas or a suggestion in what direction i can continue my search i would like to hear it :)
    – ARTLAUROO
    Oct 29, 2015 at 16:47
  • Stupid me - I should have looked harder at your question. rfkill list which was in your pastebin, shows the wifi is turned off in the hardware (hard blocked: yes) - look for the switch on your keyboard, side of the computer, or in bios... you will probably need to reboot, baased upon some of the things I've read. Oct 29, 2015 at 17:00
  • Your wireless is showing hard blocked:yes. What is the position of the wireless switch on your laptop?
    – chili555
    Oct 29, 2015 at 20:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .